[mythtv-users] Silly Question about logging

Nick Morrott knowledgejunkie at gmail.com
Wed Nov 25 18:56:22 UTC 2009


2009/11/25 Michael T. Dean <mtdean at thirdcontact.com>:
> On 11/25/2009 11:42 AM, Johnny Walker wrote:
>>
>> yeah - i'm at work and the mythbox is at home - evidently even to run
>> '--help' requires that I forward my X server connection.
>>
>
> Shouldn't on 0.22 and above.  (There there may be a completely unrelated
> issue that causes an abort if you don't.)

This doesn't work for me on 0.22-fixes over SSH:

[nick at smithers ~]$ mythfrontend --help
mythfrontend: cannot connect to X server

however...

[nick at smithers ~]$ mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 22764
MythTV Branch    : branches/release-0-22-fixes
Network Protocol : 50
Library API      : 0.22.20091023-1
QT Version       : 4.5.2
Options compiled in:
 linux release using_oss using_alsa using_pulse using_backend
using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_lirc
using_mheg using_opengl_video using_opengl_vsync using_qtwebkit
using_v4l using_x11 using_xrandr using_xv using_bindings_perl
using_bindings_python using_opengl using_ffmpeg_threads using_live
using_mheg

... does work

Maybe the help code is not handled in the same X-less scope as the version code?

Cheers,
Nick

-- 
Nick Morrott

MythTV Official wiki: http://mythtv.org/wiki/
MythTV users list archive: http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin


More information about the mythtv-users mailing list