[mythtv-users] Fan speed control using lm-sensors doesn't work. Help, please. -- SOLVED

Johnny Walker johnnyjboss at gmail.com
Wed Nov 25 23:03:34 UTC 2009


On Mon, Nov 23, 2009 at 9:36 AM, Allen Edwards
<allen.p.edwards at gmail.com> wrote:
>
>
> On Sat, Nov 14, 2009 at 10:13 PM, Allen Edwards <allen.p.edwards at gmail.com>
> wrote:
>>
>> I just searched the last year of posts and find nothing discussed on the
>> problem I am having with lm-sensors. I have a AMD 5400+ on an M3A Asus
>> mother board. We have been living with a very noisy CPU fan so today I
>> finally got around to doing something about it. First, I got a new heat
>> sink, a Thermaltake TR2-R1 and it is a bigimprovement. I checked the temp
>> with sensors and it runs about the same, about 30 idle and 40-45 under load.
>> (The bios reports over 50c on boot up. What's up with that? I guess an
>> error in the bios).
>> The problem is with trying to get lm-sensors to work. I installed all the
>> programs and got as far as running pwmconfig. All looked good, it
>> controlled the CPU fan and did a detailed profile. It got very quiet at a
>> setting of 180. But when it got to the part about testing what setting will
>> not start the fan, it didn't change the fan speed. And when I created the
>> fancontrol file and re-booted, the fan is always at max speed, which is
>> 1400RPM.
>> So one level of the program controls the fan speed, but when it comes down
>> to it, something is different and the fan speed is not controlled. I should
>> point out that this fan has 3 pins and not 4 so that may be part of the
>> problem but the fan was being controlled by the first part of pwmconfig so I
>> don't understand what is going on.
>> Any help out there? I would greatly improve the WAF if I could get that
>> fan down to about 1000RMP when the CPU is at 1000GHz and doing nothing. I
>> don't care how loud the fan is when we are watching something because the
>> sound of the show covers it up.
>> Anyone understand what I am doing wrong?
>> Allen
>
> I solved this problem. The version installed on my mythbuntu system with
> "apt-get install" was version 3.0. this version does not work. The latest
> version is 3.1 I downloaded that version from the lm_sensors web site.
> Unzipped it:tar xvjf <file>
> cd to the new directory
> used apt-get install to install the dependencies listed in the INSTALL file
> make clean (in case you had some false starts)
> make all
> make install
> I already had a sensors-detect file so did not have to repeat that
> Ran "watch sensors" in one windows to monitor what is going on
> ran pwmconfig in another window
> installed /usr/local/sbin/fancontrol in the place I use to start files and
> re-booted to test things.
> Hope this helps the next person with this problem. The fan is now so quiet
> you can't hear it. When Myth is doing something, it speeds up but usually
> you are watching something to that masks the noise, which wasn't much with
> the new fan-heatsink anyway.
> Allen

when i run pwmconfig I get this:

/usr/local/sbin/pwmconfig: There are no pwm-capable sensor modules installed

even though sensors returns:

atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage:     +0.99 V  (min =  +0.80 V, max =  +1.80 V)
 +3.3 Voltage:     +3.31 V  (min =  +2.97 V, max =  +3.63 V)
 +5 Voltage:       +5.02 V  (min =  +4.50 V, max =  +5.50 V)
 +12 Voltage:     +11.97 V  (min = +10.20 V, max = +13.80 V)
CPU FAN Speed:    2385 RPM  (min =  600 RPM)
CHASSIS FAN Speed:1240 RPM  (min =  600 RPM)
POWER FAN Speed:  4245 RPM  (min =  600 RPM)
CPU Temperature:   +42.0°C  (high = +60.0°C, crit = +95.0°C)
MB Temperature:    +39.0°C  (high = +45.0°C, crit = +95.0°C)

I tried to read the page at
http://www.lm-sensors.org/wiki/AsusFormulaHacking but at the moment
it's not making much sense to me. I could just need some sleep.

I wonder if my ASUS M3N78-EM motherboard just isn't compatible with fancontrol

Does anyone know?


>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
>


More information about the mythtv-users mailing list