[mythtv-users] ERROR: Master backend tried to connect back to itself!

Michael Tiller michael.tiller at gmail.com
Sat Nov 28 16:26:44 UTC 2009


All,

Well, it stopped now.  No idea why (after doing it for two days).  I did
restart the backend, perhaps that had something to do with it.  Perhaps I
managed (somehow) to have two backends running at once.  No idea.  Anyway,
it has gone away (although I'm still troubled as to how it happened in the
first place).

Thanks for your suggestion Nick, I'll look into that.

--
Mike

On Sat, Nov 28, 2009 at 10:48 AM, Michael Tiller
<michael.tiller at gmail.com>wrote:

> I've got a problem where my backend isn't using my PVR-150 and my HD-PVR
> for some reason.  Worked after my upgrade to 0.22 but I think a reboot
> messed something up.  I checked the logs and found that my backend seems to
> be restarting (or spawning a subprocess, not really sure what is going one)
> every 20 seconds.  I get sections in my log like the one below repeated
> every 20 seconds or so:
>
> 2009-11-28 08:44:37.803 Using runtime prefix = /usr
> 2009-11-28 08:44:37.805 Using configuration directory =
> /home/mythtv/.mythtv
> 2009-11-28 08:44:37.807 Empty LocalHostName.
> 2009-11-28 08:44:37.809 Using localhost value of mythmc
> 2009-11-28 08:44:37.816 New DB connection, total: 1
> 2009-11-28 08:44:37.820 Connected to database 'mythconverg' at host:
> localhost
> 2009-11-28 08:44:37.822 Closing DB connection named 'DBManager0'
> 2009-11-28 08:44:37.824 Connected to database 'mythconverg' at host:
> localhost
> 2009-11-28 08:44:37.827 Current MythTV Schema Version (DBSchemaVer): 1244
> 2009-11-28 08:44:37.830 MythBackend: Starting up as the master server.
> 2009-11-28 08:44:37.835 New DB connection, total: 2
> 2009-11-28 08:44:37.838 Connected to database 'mythconverg' at host:
> localhost
> 2009-11-28 08:44:37.840 New DB connection, total: 3
> 2009-11-28 08:44:37.842 Connected to database 'mythconverg' at host:
> localhost
> *2009-11-28 08:44:38.524 ERROR: Master backend tried to connect back to
> itself!
> 2009-11-28 08:44:38.534 ERROR: Master backend tried to connect back to
> itself!
> *2009-11-28 08:44:39.540 ret_pid(0) child(9993) status(0x0)
> 2009-11-28 08:44:40.053 ret_pid(9993) child(9993) status(0x0)
> 2009-11-28 08:44:40.055 External Tuning program exited with no error
> 2009-11-28 08:44:40.065 New DB scheduler connection
> 2009-11-28 08:44:40.067 Connected to database 'mythconverg' at host:
> localhost
> 2009-11-28 08:44:40.069 Scheduler, Warning: Listings source 'Dish Network'
> is defined, but is not attached to a card input.
> 2009-11-28 08:44:40.073 Scheduler, Warning: Listings source 'Digital
> Broadcast' is defined, but is not attached to a card input.
> 2009-11-28 08:44:40.076 Scheduler, Warning: Listings source 'Comcast' is
> defined, but is not attached to a card input.
> 2009-11-28 08:44:40.091 Enabling Upnpmedia rebuild thread.
>
> I have no idea what is going on here and/or what this has to do with my
> other issue (of not finding some of my recording devices) but it doesn't
> look good.  Any ideas?
>
> --
> Mike
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091128/4183de59/attachment.htm>


More information about the mythtv-users mailing list