[mythtv-users] mythnuv2mkv job queue error on some

auric auric at aanet.com.au
Sun Nov 29 21:01:30 UTC 2009


> Date: Sat, 28 Nov 2009 19:42:58 -0500
> From: Bobby Gill <brownitus at gmail.com>
> Subject: Re: [mythtv-users] mythnuv2mkv job queue error on some
> 	recordings
> To: Discussion about mythtv <mythtv-users at mythtv.org>
> Message-ID:
> 	<8c675e700911281642o602860c7n76d44c3a2730c1a2 at mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> > Bob, Ignore the PATH error, this is the only error that the myth backend
> > can and will report for any failure of a job script. (I just checked the
> > latest myth source and this situation has changed but I won't update the
> > script until majority are on 0.22)
> > You need to look in the mythnuv2mkv log file for the actual problem.
> > This is LOGBASEDIR/mythnuv2mkvPID.log where LOGBASEDIR is a variable in
> > the script, defaults to /var/tmp and PID is the Process ID of the
> > script. You can get the PID from the System Status Job Queue or Log
> > Entries screens as [PID]. However I find the easiest way is do a
> > "ls -lrt /var/tmp/mythnuv2mkv*log" and the most recent
> > mythnuv2mkv{PID}.log will be at the end. (ls -lrt is a long listing
> > ordered by reverse time).
> >
> > Auric
> >
> 
> Thanks a bunch Auric, I did the ls and just cat'd the few most recent,
> here's one that error'd:
> 
> тт> cat /var/tmp/mythnuv2mkv7613.log
> 28/11,15:35 [7613] INFO Changed to high quality.
> 28/11,15:35 [7613] INFO Changed to avi,lavc.
> 28/11,15:35 [7613] INFO 1054 20090516120000 matches Good Eats   Kinda Blue
> (Blueberry) (/media/myth//1054_20090516120000.mpg)
> 28/11,15:36 [7613] INFO 480i or 480p 720x480 NA 4:3 (Found in Channel)
> 29.970 FPS Audio Rate 48000 Channels 2
> 28/11,15:36 [7613] INFO Crop to 704:464:8:8. Scale to 528x400.
> 28/11,15:36 [7613] INFO Deinterlace filter added.
> 28/11,15:36 [7613] INFO If progressive this is wrong use --deinterlace=NO.
> 28/11,15:36 [7613] INFO You may need Invtelecine rather than Deinterlace.
> (--deinterlace=NO --invtelecine=YES).
> 28/11,15:36 [7613] INFO Video Encoder: mencoder -idx
> /var/tmp/mythnuv2mkv7613/vidout -demuxer rawvideo -rawvideo
> w=720:h=480:fps=29.970              -audiofile
> /var/tmp/mythnuv2mkv7613/audout -audio-demuxer rawaudio -rawaudio
> rate=48000:channels=2              -ovc lavc -lavcopts
> vcodec=mpeg4:threads=1:mbd=2:trell:v4mv:last_pred=2:dia=-1:vmax_b_frames=2:vb_strategy=1:cmp=3:subcmp=3:precmp=0:vqcomp=0.6:vbitrate=1173:vpass=1:turbo
> -passlogfile /var/tmp/mythnuv2mkv7613/2pass.log             -oac mp3lame
> -lameopts vbr=2:br=256             -vf
> pp=fd,softskip,crop=704:464:8:8,scale=528:400,harddup -sws 7
> -aspect 1.333333333 -force-avi-aspect 4:3 -o /dev/null.
> 28/11,15:36 [7613] START Starting lavc 1st video pass trans of
> /media/myth//1054_20090516120000.mpg. vbr 1173 abr 256.
> 28/11,15:36 [8039] INFO Starting monitoring process.
> 28/11,15:36 [7613] ERROR Skipping /media/myth//1054_20090516120000.mpg.
> Problem with 1st video pass of 2.
> --------------------------------------------------------------------------------
> 28/11,15:36 [7613] INFO Exiting. Errored.
> 28/11,15:36 [7613] ERROR This error could be for many reasons. Mythtv will
> report unable to find executable, this is incorrect.
> тт[ 19:40 ][ ~ ]
> 
> 
> I can't really gather what the problem is here from the output?
> 
> Thanks
> Bob

Unfortunately a more difficult error to track down.
Looks like mencoder has failed for some reason.
There will be a directory /var/tmp/mythnuv2mkvPID/
(/var/tmp/mythnuv2mkv7613 in this case)
In there will be mencoder.op and transcode.op. These are the outputs
from mencoder and mythtranscode. Hopefully these may give a clue as to
what is happening.

Auric.




More information about the mythtv-users mailing list