[mythtv-users] Broken 9.10 mythbuntu - questions

Jonno jonnojohnson at gmail.com
Mon Nov 30 17:12:26 UTC 2009


On Mon, Nov 30, 2009 at 11:02 AM, Jonno <jonnojohnson at gmail.com> wrote:
> I need some advice. I had been running Mythbuntu 9.04 successfully for
> the past 7 months or so but since I upgraded to 9.10 I can't watch
> recordings or LiveTV for more than about 30 mins without a frame
> buffering issue causing a failure.
>
> If anyone can supply answers to the following questions then I hope it
> will help me either debug the problem or find a solution.
>
> 1. How can I check if there is a problem with the tuner card (pchdtv
> 5500)? I seem to get decent signal strength. Is there a utility I can
> use to test it? All my signals are ATSC OTA so are raw mpeg2 I think.
> I don't do any transcoding.
>
> 2. How can I test if there is a problem with my HDD. I have my
> recordings directory mounted on a 1TB SATA drive which is plugged in
> to the m/b SATA port but housed in an external eSATA enclosure with
> it's own power supply. It is xfs formatted and mounted with
> allocsize=512m. I've run hdparm a couple of times and get something
> like:
>  Timing buffer-cache reads:  1000 MB/sec
>  Timing buffered disk reads:  100 MB/sec
> The drive does seem to be increasing in fragmentation quite quickly.
>
> 3. My backend log contains a lot of this when recording:
> 2009-11-23 06:59:00.711 [mpeg2video @ 0x7f0cbd3c7820]ac-tex damaged at 50 0
> 2009-11-23 06:59:00.712 [mpeg2video @ 0x7f0cbd3c7820]00 motion_type at 26 3
> and my frontend log contains the same messages plus a lot of this when playing:
> 2009-11-22 21:55:10.796 [mpeg2video @ 0x7f35b0d89820]Warning MVs not available
> 2009-11-22 21:55:13.384 [ac3 @ 0x7f35b0d89820]frame CRC mismatch
> 2009-11-22 21:55:13.415 [ac3 @ 0x7f35b0d89820]incomplete frame
> 2009-11-22 21:55:13.416 [ac3 @ 0x7f35b0d89820]invalid frame size
> I've no idea what this might refer to. Since I'm recording straight
> from OTA signals I didn't think this would be very taxing on my system
> which is:
> Asus P1-AH2 Barebones System with on-board Nvidia 6150
> AMD Athlon x2 2.3GHz
> 2GB DDR2 SDRAM 800
> 320GB Internal IDE mythtv boot drive
> 1TB SATA drive for recordings
>
> 4. If I can't figure out what the problem(s) is(are), what are my
> options as far as upgrading mythtv? I've never built something from
> source so:
> a) is there a repository I can add for updated mythtv (0.22-fixes?)
> rather than the static Mythbuntu one? This would be the easiest option
> for me but I don't know if it exists.
> b) what would I need to do to go back to 9.04? Will I have all kinds
> of nightmares with databases?
> b) if I have to build code where do I need to go to start learning how
> to do that? I've done some googling about svn but I can't find much to
> explain this stuff to a non-programmer.

One thing I forgot to mention, I thought that the problem might be
with the recording part (rather than the viewing) so I tried to watch
an old episode that was recorded way before I did the upgrade and I
still had the same problem of the video frame buffering. Seems like
the problem already existed with the recordings done with 0.21 and the
viewing part just handled it better - unless I'm totally missing
something.


More information about the mythtv-users mailing list