[mythtv-users] HD-PVR input issues:

John P Poet jppoet at gmail.com
Sat Apr 10 01:50:20 UTC 2010


On Fri, Apr 9, 2010 at 6:58 PM, Mark <fairlane at springcom.com> wrote:
>
>> KERNEL=="video*", ATTR{name}=="ivtv0 encoder MPG",
>> ATTRS{device}=="0x244e"  , SYMLINK+="pvr150"
>>
>> KERNEL=="video*", ATTR{name}=="Hauppauge HD PVR",
>> ATTRS{vendor}=="0x8086", SYMLINK+="hdpvr"
>>
>> KERNEL=="dvb*.frontend*", ATTRS{vendor}=="0x13d0", SYMLINK+="frontend0"
>>
>> These are my rules they are placed in a folder under
>> etc/udev/60-simlinks.rules
>>
>> I then stop the backend,run mythtv-setup..Under video cards instead of
>> /dev/video0 put, /dev/hdpvr..reboot or restart UDEV and it should make
>> your simlink to your hdpvr...
>> Ubuntu has a script that is available that will figure all this out for
>> you,but I don't know if it will work under arch...
>>
>
> I pulled the HDPVR off the backend, went to a windows computer and
> installed the latest drivers, which supposedly installed the latest
> firmware (not sure), then put it back onto the backend.
>
> I still get this during a cat /dev/video4 > test.ts:
>
> [root at cyclops mythtv]# cat /dev/video4 > test.ts
> cat: write error: Bad address

Are you using the udev rule that greg posted?  If so, you should be
using /dev/hdpvr, not /dev/video4.

Each time your system boots, it is possible that the HD-PVR could be
attached to a different /dev/videoX.  The udev rule results in a
mapping of whatever /dev/videoX the HD-PVR is on, to the name
/dev/hdpvr, so that myth (or whatever) can reliably talk to it.


John
-- 
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?


More information about the mythtv-users mailing list