[mythtv-users] Avenard Jaunty mythtv-backend/upstart-job problem

Jean-Yves Avenard jyavenard at gmail.com
Wed Apr 14 23:48:52 UTC 2010


Hi

On 15 April 2010 06:24, John Veness <John.Veness.mythtv at pelago.org.uk> wrote:
> Hi,
>
> My combined FE/BE is running Ubuntu Jaunty (9.04), using JYA's avenard.org
> repo, specifically:
>
> http://www.avenard.org/files/ubuntu-repos jaunty release
>
> This has been fine and updating successfully for several months. Currently I
> have 0.22.0-fixes23953-0ubuntu1 installed.
>
> Recently a new version, 0.22.0-fixes24035-0ubuntu1 came out, but the
> mythtv-backend component of that wants to be removed. When I check why, I
> see that it depends on ubuntu-job, but that doesn't exist in jaunty as far
> as I can see. Older versions of mythtv-backend don't have that dependency.
>
> Is there any fix for this, other than updating Ubuntu?

That's surprising... (if not impossible :P )

The 0.22 packages haven't been updated since they first came out last
year. The only difference is the SVN revision used... The packages
source code is the same...

The packages are also build in a jail in a clean install for each OS.
So you can't have a dependency on something that doesn't exist in that
particular version.

Those are the current dependencies:
 Depends: mythtv-common (= 2:0.22.0-fixes24035-0ubuntu1),
mythtv-transcode-utils (= 2:0.22.0-fixes24035-0ubuntu1), libavc1394-0
(>= 0.5.3), libc6 (>= 2.4), libfreetype6 (>= 2.2.1), libgcc1 (>=
1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1,
libiec61883-0 (>= 1.1.0), libmyth-0.22-0 (>= 2:0.22.0-fixes24035),
libpulse0 (>= 0.9.14), libqt4-network (>= 4.5.0~+rc1), libqt4-sql (>=
4.5.0~+rc1), libqt4-xml (>= 4.5.0~+rc1), libqtcore4 (>= 4.5.0~+rc1),
libqtgui4 (>= 4.5.0~+rc1), libraw1394-8, libstdc++6 (>= 4.1.1),
libx11-6, libxext6, libxinerama1, libxrandr2 (>= 2:1.2.99.2), libxv1,
libxvmc1, libxxf86vm1, zlib1g (>= 1:1.1.4), cron, wget, zenity |
kdebase-bin, gksu | kdebase-bin, ttf-liberation | msttcorefonts,
libmyth-perl, xterm, debconf (>= 0.5) | debconf-2.0, upstart-job

No ubuntu-job, only reference is on upstart-job

Are you sure you're still using the same repository? (jaunty release)


More information about the mythtv-users mailing list