[mythtv-users] 10.04 volume issue

Jim Chisholm jim at electron.phys.dal.ca
Fri Apr 30 13:32:07 UTC 2010


On 10-04-30 08:04 AM, Josh White wrote:
> Card: HDA Intel
> Chip: VIA VT1708B 8-Ch
>
> So I just updated to ubuntu 10.04/myth .23 last night, and now I'm 
> having problems.  On an SD frontend, when I skip ahead, or back, the 
> master & front volumes resets to zero (as indicated by another machine 
> running alsamixer via ssh).  The volume in myth still shows as 100% 
> (PCM).  To rule out that this is a problem with my remote, I 
> regenerated the key mappings, which have worked in the past, and seem 
> to work correctly in every other way.
>
> This is what I see when I run from a command line. To give you an idea 
> of what it should say, I ran mythfrontend, selected a recording, 
> skipped ahead a couple of times, then exited mythfrontned.
>
> josh at Myth-Livingroom:~$ mythfrontend
> 2010-04-30 06:58:07.118 mythfrontend version: 
> branches/release-0-23-fixes [24158] www.mythtv.org <http://www.mythtv.org>
> 2010-04-30 06:58:07.119 Using runtime prefix = /usr
> 2010-04-30 06:58:07.119 Using configuration directory = /home/josh/.mythtv
> 2010-04-30 06:58:07.537 Empty LocalHostName.
> 2010-04-30 06:58:07.537 Using localhost value of Myth-Livingroom
> 2010-04-30 06:58:07.537 Testing network connectivity to '192.168.1.5'
> 2010-04-30 06:58:07.548 New DB connection, total: 1
> 2010-04-30 06:58:07.550 Connected to database 'mythconverg' at host: 
> 192.168.1.5
> 2010-04-30 06:58:07.551 Closing DB connection named 'DBManager0'
> 2010-04-30 06:58:07.562 ScreenSaverX11Private: Gnome screen saver 
> support enabled
> 2010-04-30 06:58:07.562 DPMS is active.
> 2010-04-30 06:58:07.564 Primary screen: 0.
> 2010-04-30 06:58:07.567 Connected to database 'mythconverg' at host: 
> 192.168.1.5
> 2010-04-30 06:58:07.569 Using screen 0, 1024x768 at 0,0
> 2010-04-30 06:58:07.593 Desktop video mode: 1024x768 60.006 Hz
> 2010-04-30 06:58:07.619 MythUI Image Cache size set to 20971520 bytes
> 2010-04-30 06:58:07.782 AudioPulseUtil: Suspend Success
> 2010-04-30 06:58:07.782 Enabled verbose msgs:  important general
> 2010-04-30 06:58:07.791 Primary screen: 0.
> 2010-04-30 06:58:07.792 Using screen 0, 1024x768 at 0,0
> 2010-04-30 06:58:07.793 Using theme base resolution of 1280x720
> 2010-04-30 06:58:07.807 LIRC: Successfully initialized '/dev/lircd' 
> using '/home/josh/.mythtv/lircrc' config
> 2010-04-30 06:58:07.807 JoystickMenuThread Error: Joystick disabled - 
> Failed to read /home/josh/.mythtv/joystickmenurc
> 2010-04-30 06:58:07.879 Using Frameless Window
> 2010-04-30 06:58:07.975 Using the OpenGL painter
> 2010-04-30 06:58:08.109 XMLParseBase: Loaded base theme from 
> '/usr/share/mythtv/themes/Mythbuntu/base.xml'
> 2010-04-30 06:58:08.115 XMLParseBase: Loaded base theme from 
> '/usr/share/mythtv/themes/default-wide/base.xml'
> 2010-04-30 06:58:08.121 XMLParseBase: Loaded base theme from 
> '/usr/share/mythtv/themes/default/base.xml'
> 2010-04-30 06:58:08.121 XMLParseBase, Error: Unable to load window 
> 'backgroundwindow' from base
> 2010-04-30 06:58:08.133 Current MythTV Schema Version (DBSchemaVer): 1254
> 2010-04-30 06:58:08.790 Registering Internal as a media playback plugin.
> 2010-04-30 06:58:08.803 Current MythVideo Schema Version 
> (mythvideo.DBSchemaVer): 1032
> 2010-04-30 06:58:08.871 MediaMonitorUnix::AddDevice() - empty device path.
> 2010-04-30 06:58:08.871 MediaMonitorUnix::AddDevice() - empty device path.
> 2010-04-30 06:58:08.871 MediaMonitorUnix::AddDevice() - empty device path.
> 2010-04-30 06:58:08.874 Cannot load language en_us for module mythvideo
> 2010-04-30 06:58:08.878 XMLParseBase: Loading window theme from 
> /usr/share/mythtv/themes/Mythbuntu/menu-ui.xml
> 2010-04-30 06:58:08.927 Loading menu theme from 
> /usr/share/mythtv/themes/mediacentermenu//mainmenu.xml
> 2010-04-30 06:58:08.936 Found mainmenu.xml for theme 'Mythbuntu'
> 2010-04-30 06:58:09.153 Using NV NPOT texture extension
> 2010-04-30 06:58:09.212 MythContext: Connecting to backend server: 
> 192.168.1.5:6543 <http://192.168.1.5:6543> (try 1 of 1)
> 2010-04-30 06:58:09.213 Using protocol version 56
> 2010-04-30 06:58:11.731 New DB connection, total: 2
> 2010-04-30 06:58:11.732 Connected to database 'mythconverg' at host: 
> 192.168.1.5
> 2010-04-30 06:58:11.735 XMLParseBase: Loading window theme from 
> /usr/share/mythtv/themes/Mythbuntu/recordings-ui.xml
> 2010-04-30 06:58:15.647 TV: Attempting to change from None to 
> WatchingPreRecorded
> 2010-04-30 06:58:16.355 AFD: Opened codec 0x4ea30b0, id(MPEG2VIDEO) 
> type(Video)
> 2010-04-30 06:58:16.355 AFD: codec MP2 has 2 channels
> 2010-04-30 06:58:16.355 AFD: Opened codec 0x4ea06d0, id(MP2) type(Audio)
> 2010-04-30 06:58:16.541 Opening audio device 'default'. ch 2(2) sr 
> 48000 (reenc 0)
> 2010-04-30 06:58:16.541 Opening ALSA audio device 'default'.
> 2010-04-30 06:58:16.625 Mixer unable to find control Master
> 2010-04-30 06:58:16.625 Mixer unable to find control Master
> 2010-04-30 06:58:17.397 VDPAU: Created 2 output surfaces.
> 2010-04-30 06:58:17.397 VDPAU: Version 1
> 2010-04-30 06:58:17.397 VDPAU: Information NVIDIA VDPAU Driver Shared 
> Library  195.36.15  Fri Mar 12 01:18:10 PST 2010
> 2010-04-30 06:58:17.397 VDPAU: Created VDPAU render device 1024x768
> 2010-04-30 06:58:17.408 NVP(0): Forcing decode extra audio option on 
> (Video method requires it).
> 2010-04-30 06:58:17.409 FilterManager: Failed to load filter 
> 'colorspace', no such filter exists
> 2010-04-30 06:58:17.411 OSD Theme Dimensions W: 1280 H: 720
> 2010-04-30 06:58:17.556 TV: Changing from None to WatchingPreRecorded
> 2010-04-30 06:58:17.557 New DB connection, total: 3
> 2010-04-30 06:58:17.557 Realtime priority would require SUID as root.
> 2010-04-30 06:58:17.558 Connected to database 'mythconverg' at host: 
> 192.168.1.5
> 2010-04-30 06:58:17.576 Video timing method: USleep with busy wait
> 2010-04-30 06:58:17.583 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:17.587 VDPAU: Added 2 output surfaces (total 4, max 4)
> 2010-04-30 06:58:17.587 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:17.615 ScreenSaverX11Private: DPMS Deactivated 1
> 2010-04-30 06:58:19.254 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:21.846 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:23.395 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:23.984 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:23.986 [mpegvideo_vdpau @ 0x7f1528b63360]warning: 
> first frame is no keyframe
> 2010-04-30 06:58:26.764 TV: Attempting to change from 
> WatchingPreRecorded to None
> 2010-04-30 06:58:26.770 TV: Changing from WatchingPreRecorded to None
> 2010-04-30 06:58:26.770 ScreenSaverX11Private: DPMS Reactivated 1
> 2010-04-30 06:58:29.853 AudioPulseUtil: Resume Success
> 2010-04-30 06:58:29.853 Deleting UPnP client...
> Error in my_thread_global_end(): 1 threads didn't exit
>
>
>
> Ideas?
>
> -Josh
>
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>    
Hi Josh
Well all I can do is commiserate, since upgrading to 10.04 I have had a 
never-ending string of audio difficulties.
I'm not given to harshness but IMO that blight that is pulseaudio needs 
to be ripped out of your system by the roots.
I've spent most of my time rebooting my Myth 0.23 box (usually 3 reboots 
is necessary) to re-gain
lost audio after my FE/BE crashes to the desktop with subsequent total 
loss of audio and I'm convinced that it's solely due to Ubuntu's 
incorporation of a sound server that has basically (again, IMO) ruined 
what has been a very solid and proven esound architecture.
The internal player crashes consistently with WMV3 files, external 
mplayer is better but not by much.
Mythtv I'm sure is more finely tuned to system resources than some other 
applications and as such with pulseaudio enabled I've been pretty much 
relegated to XBMC and SageTV (which runs surprisingly well with zero 
crashes unless the audio has been previously brought down by a 
myth-pulseadio crash). The logs are full of pulseadio sink errors.
I haven't experienced so much frustration with Linux since the 21st 
floppy of a 23 floppy Slackware distribution invariably being defective 
25 years ago!
Hopefully you'll get better mileage but I've had it with pulseaudio.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100430/b01f90e9/attachment.htm>


More information about the mythtv-users mailing list