[mythtv-users] [OT] LIRC multiple devices question/problem

Jarod Wilson jarod at wilsonet.com
Fri Dec 3 05:06:41 UTC 2010


On Dec 2, 2010, at 11:56 PM, Tom Lichti wrote:

> This is not specifically a MythTV question, but I know there are many
> people here who can help (yes Jarod, I'm looking at you.. :) ) me out.

Who, me?

> I have a MCE USB receiver, and an IguanaIR receiver/transmitter that I
> am trying to use on my frontend. Originally I just had the MCE
> receiver, but I want to control the volume and power on my TV, so I
> added the Iguana unit to do that. I could not get the two to work
> together, in that it seems I could only use one or the other with
> LIRC, so I am currently using just the Iguana unit, but as a receiver,
> it, to be blunt, sucks. It misses probably half of the events. As a
> transmitter it works, but it's a bit slow. What I would like to do is
> use the receiver portion of the MCE unit, and the transmitter portion
> of the Iguana unit, at the same time. The frontend is running latest
> trunk SVN, on FC13, LIRC is 0.8.6-7 recompiled with IguanaIR support.
> 
> I have tried to follow the guide here:
> http://www.lirc.org/html/configure.html but I think I have an issue
> with the /dev/lirc2 node, I can start the second instance of lirc (for
> the mceusb device) but when I try to run irw and connect to it I get
> the following:
> 
> Dec  2 23:51:42 fe2 lircd-0.8.6[5275]: accepted new client on
> /var/run/lirc/lircd2
> Dec  2 23:51:42 fe2 lircd-0.8.6[5275]: could not open /dev/lirc2
> Dec  2 23:51:42 fe2 lircd-0.8.6[5275]: default_init(): No such device or address
> Dec  2 23:51:42 fe2 lircd-0.8.6[5275]: Failed to initialize hardware
> 
> Here are my device nodes:
> 
> [root at fe2 etc]# ls -ltr /dev/lirc*
> crw-rw-r-- 1 root root 250, 1 Dec  2 23:24 /dev/lirc2
> crw-rw---- 1 root root 250, 0 Dec  2 23:43 /dev/lirc0
> [
> I created lirc2 manually, but it doesn't seem to work.

Yeah, not gonna. Unless you're running a really old kernel, you should
never have to create a device node, it should be automagically created
when there's actually a device backing it. In this case, there's no
device backing /dev/lirc2. The iguanair hardware doesn't use a kernel
driver, its a userspace driver. No /dev/lircX for userspace driven IR
hardware.


> I am also a bit
> confused as to what driver to use. Without the iguanaIR device
> connected, I dpon't specify a driver for the mceusb device, I just
> start LIRC and it works. for the second lircd instance (for the mceusb
> device) I started it with:
> 
> lircd --device=/dev/lirc2 --output=/var/run/lirc/lircd2
> --pidfile=/var/run/lirc/lircd2.pid
> 
> Is that the problem?

lircd --driver=iguanair --device=/dev/iguanaIR/0, etc., etc., or similar,
if I'm thinking clearly.

The IguanaWorks guys were kind enough to send me hardware a while back,
but I'm not hugely familiar with it... The /dev/iguanaIR/0 thing should
change to /var/run/iguanaIR/0 or similar in the future (I provided them
a number of patches I used to sanitize an iguanaIR package I submitted
for Fedora package review), but there should also be a symlink to 0 that
matches the name of the device, if you've given it one, following their
first-time initialization steps.

-- 
Jarod Wilson
jarod at wilsonet.com





More information about the mythtv-users mailing list