[mythtv-users] Mythfilldatabase adds an incorrect XMLTVID

Gabe Rubin gaberubin at gmail.com
Fri Dec 3 19:31:44 UTC 2010


On Fri, Dec 3, 2010 at 11:12 AM, Robert Eden <rmeden at yahoo.com> wrote:
> On 12/3/2010 12:32 PM, Gabe Rubin wrote:
>>
>> On Thu, Dec 2, 2010 at 9:55 PM, Robert Eden<rmeden at yahoo.com>  wrote:
>>>
>>> On 12/2/2010 6:15 PM, Gabe Rubin wrote:
>>>>
>>>> Hi list,
>>>>
>>>> Whenever I run mythfilldatabse, it adds the channel The Movie Channel
>>>> HD (Pacific) with an XMLTVID of 50600 for channels 179 and 357.  Both
>>>> of these channels are listed in my schedules direct lineup as The
>>>> Movie Channel HD with an XMLTVID of 35329.  Indeed, there is no
>>>> channel in my schedules direct lineup with an XMLTVID of 50600.  So,
>>>> my database has two different XMLTVIDs for channels 179 and 357 (50600
>>>> and 35329).
>>>>
>>>> When I try to delete the channels with the incorrect id, it gets
>>>> repopulated when I reun mythfilldatabase.  I can make the channels not
>>>> visible; however, I am trying to figure out how they keep popping back
>>>> in there.  When I have failed to do this in the past, I get inaccurate
>>>> guide data for those channels, which causes incorrect recordings.  I
>>>> am not 100% sure that the problem of incorrect recordings is solved
>>>> even when I make the channels not visible because I get recordings
>>>> that don't match with I expected (or what myth tells me they are) from
>>>> these channels, but I can't confirm after the fact what was expected
>>>> to be aired (i.e., it could also be incorrect guide data and not an
>>>> issue with incorrect XMLTVID).
>>>>
>>>> I would like to fix this problem.  Any ideas?  Should I contact the SD
>>>> people?
>>>
>>> View raw listing data at http://schedulesdirect.org/getdata  and search
>>> for
>>> "35329"  that may provide a clue.
>>>
>>> BTW, it's XMLID not XMLTVID... XMLTV has nothing to do with it. :)
>>>
>>> Robert
>>> XMLTV
>>> Schedules Direct
>>
>> This is what I get (btw, I believe that 50600 is the incorrect XMLID,
>> and channels 179 and 357 are identical on my cable lineup)
>>
>> <station id='50600'>
>> <callSign>TMCHDP</callSign>
>> <name>The Movie Channel HD (Pacific)</name>
>> <affiliate>PAY</affiliate>
>> </station>
>>
>> ****
>> <map station='50600' channel='179' from='2010-02-18'/>
>>
>> ****
>> <map station='50600' channel='357' from='2006-06-16'/>
>>
>> ****
>> <schedule program='MV002610740000' station='50600'
>> time='2010-12-03T17:35:00Z' duration='PT01H55M' stereo='true'
>> hdtv='true' closeCaptioned='true'/>
>>
>> ****
>>
>> <station id='35329'>
>> <callSign>TMCHD</callSign>
>> <name>The Movie Channel HD</name>
>> <affiliate>PAY</affiliate>
>> </station>
>>
>> ****
>>
>> <map station='35329' channel='179' from='2010-08-13'/>
>>
>> ****
>>
>> <map station='35329' channel='357' from='2010-08-13'/>
>>
>>
>> ****
>>
>> <schedule program='MV002515650000' station='35329'
>> time='2010-12-03T18:05:00Z' duration='PT01H55M' stereo='true'
>> hdtv='true' closeCaptioned='true'/>
>
>> Whenever I run mythfilldatabse, it adds the channel The Movie Channel
>>  HD (Pacific) with an XMLTVID of 50600 for channels 179 and 357.
>
> Based on what you saw on /getdata, that is the correct response. IMHO.
>
> Are you saying the SD "lineup report" shows XMLID of 35329?
>
> If that's the case, a re-add lineup will probably fix it, but please send an
> email to support at sd so I can report the issue to Tribune as they need to
> know if their Lineup-API and Data-API databases are out of sync.  it
> shouldn't be happening any more. (they supposidly fixed that bug)  Please
> don't run the re-add so Tribune can see it broken.
>

This is what shows up in the report:
179 	 	35329 	TMCHD 	The Movie Channel HD
357 	 	35329 	TMCHD 	The Movie Channel HD

There is no 50600 XMLID in my report.

I stupidly did not read the full email before I went ahead and did a
re-add lineup.  My apologies, but it fixed the problem.  I will still
forward this to schedules direct though.


More information about the mythtv-users mailing list