[mythtv-users] 3 audio devices on same time

Josu Lazkano josu.lazkano at gmail.com
Thu Dec 9 14:51:07 UTC 2010


Thanks for your reply.

2010/12/9 Jean-Yves Avenard <jyavenard at gmail.com>:
> On 9 December 2010 13:30, Josu Lazkano <josu.lazkano at gmail.com> wrote:
>
>> I must configure it on the frontend or on the .asoundrc file?
>
> in .asoundrc
>
>>
>> On XBMC I get it working with this file:
>>
>> pcm.!default {
>> type plug
>> slave {
>> pcm "both"
>> }
>> }
>
> then you use ALSA:default in mythtv (enter it manually) ; you can
> click after you've typed ALSA:default on the scan button to see if it
> works or not.

I config as ALSA:default this way: http://dl.dropbox.com/u/1541853/ALSA.png
>
> Make sure you select stereo though , and disable AC3 and DTS ; as it
> won't work properly otherwise.
>
> Passthrough would only work if all your device supports passthrough
> and mythtv auto-setup of passthrough would probably not work (though
> it may, I've never tested this kind of things).
>
> If you get some warning in the log when myth is trying to set the
> audio device for passthrough, it means it didn't work, then If you
> want passthrough to work, you probably would have to override the
> passthrough device ; and in your .asoundrc add a pcm that sets the
> iec958 bit
Here is what I get on the mythfronted shell:

2010-12-09 11:47:38.980 ALSA, Error: No playback configurations
available: Argumento inválido
2010-12-09 11:47:38.991 ALSA, Error: No playback configurations
available: Argumento inválido
2010-12-09 11:47:39.246 PulseAudio Error: ContextConnect, context
connection failed or terminated: Connection refused
2010-12-09 12:00:22.944 ALSA, Error: No playback configurations
available: Argumento inválido
2010-12-09 12:00:22.955 ALSA, Error: No playback configurations
available: Argumento inválido
2010-12-09 12:00:23.132 PulseAudio Error: ContextConnect, context
connection failed or terminated: Connection refused




>
> Something like this:
> pcm.hdmipassthrough {
>    type hooks
>    slave.pcm {
>        type hw
>        card 0
>        device 0
>    }
>    hooks.0 {
>        type ctl_elems
>        hook_args [
>        {
>            name "IEC958 Playback Default"
>            index 0
>            lock true
>            preserve true
>            value [ 0x06 0x82 0x00 0x01 ]
>        }
>        {
>            name "IEC958 Playback Switch"
>            index 0
>            lock true
>            preserve true
>            value true
>        }
>        ]
>    }
> }
> or something similar and re-use the same type of rules you are currently using.
> slaves.a {
> pcm "hdmipassthrough"
> channels 2
> }

I config this way the .asoundrc:

$ cat .asoundrc
pcm.!default {
	type plug
	slave {
		pcm "both"
	}
}

pcm.both {
	type route
	slave {
		pcm multi
		channels 6
	}
	ttable.0.0 1.0
	ttable.1.1 1.0
	ttable.0.2 1.0
	ttable.1.3 1.0
	ttable.0.4 1.0
	ttable.1.5 1.0
}

pcm.multi {
	type multi
	slaves.a {
		pcm "tv"
		channels 2
	}
pcm.hdmipassthrough {
       type hooks
       slave.pcm {
               type hw
               card 0
               device 0
       }
       hooks.0 {
               type ctl_elems
               hook_args [
               {
                       name "IEC958 Playback Default"
                       index 0
                       lock true
                       preserve true
                       value [ 0x06 0x82 0x00 0x01 ]
               }
               {
                       name "IEC958 Playback Switch"
                       index 0
                       lock true
                       preserve true
                       value true
               }
               ]
       }
}
slaves.a {
	pcm "hdmipassthrough"
	channels 2
}
slaves.b {
	pcm "receiver"
	channels 2
}
slaves.c {
	pcm "analog"
	channels 2
}
bindings.0.slave a
bindings.0.channel 0
bindings.1.slave a
bindings.1.channel 1
bindings.2.slave b
bindings.2.channel 0
bindings.3.slave b
bindings.3.channel 1
bindings.4.slave c
bindings.4.channel 0
bindings.5.slave c
bindings.5.channel 1
}

pcm.tv {
	type hw
	card 0
	device 3
	channels 2
}

pcm.receiver {
	type hw
	card 0
	device 1
	channels 2
}

pcm.analog {
	type hw
	card 0
	device 0
	channels 2
}

It looks that there is problem with PulseAudio. I don't use it, is it
a good idea to uninstall?

Thanks for all your help and sorry for my poor english.

Best regards.

>
> You will get better feedback in the alsa mailing list for this
> advanced use of alsa.
>
> JY
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>



-- 
Josu Lazkano


More information about the mythtv-users mailing list