[mythtv-users] VDPAU problem on HD-PVR content after update to b0.24-593-g40c1c32 master branch

Jean-Yves Avenard jyavenard at gmail.com
Sun Dec 19 10:46:45 UTC 2010


On 19 December 2010 14:27, John Nissley <jnissley at nissley.org> wrote:
> I just updated to the latest version on mythtv via git and am seeing some
> issues with VDPAU playback with any of my HD-PVR content.  Things worked
> fine until the upgrade so I am hoping that someone can assist me with
> finding the problem.  Any content recorded on my HD Homerun is working fine.
>
> Here is the output from the frontend log.
> 2010-12-18 21:04:34.015 OSD: Base theme size: 1280x720
> 2010-12-18 21:04:34.015 OSD: Scaling factors: 1.3125x1.45833
> 2010-12-18 21:04:34.017 Player(1): Video timing method: USleep with busy
> wait
> 2010-12-18 21:04:34.019 TV: Changing from None to WatchingPreRecorded
> 2010-12-18 21:04:34.101 ScreenSaverX11Private: DPMS Deactivated 1
> 2010-12-18 21:04:34.144 VDPAU: Added 2 output surfaces (total 4, max 4)
> 2010-12-18 21:04:41.560 Marking recording as unwatched
> 2010-12-18 21:04:41.752 TV: Attempting to change from WatchingPreRecorded to
> None
> 2010-12-18 21:04:41.851 VDPAU Warning: Display pre-empted.
> 2010-12-18 21:04:41.851 VDPAU Error: Error at mythrender_vdpau.cpp:873 (#2,
> The display was pre-empted, or a fatal error occurred.)
> 2010-12-18 21:04:41.851 VDPAU: Attempting to re-create VDPAU resources.
> 2010-12-18 21:04:41.893 VDPAU: Re-created output surfaces.
> 2010-12-18 21:04:41.904 VDPAU: Re-created decoders.
> 2010-12-18 21:04:41.904 VDPAU Error: Error at mythrender_vdpau.cpp:873 (#3,
> An invalid handle value was provided.)

Re-install nvidia drivers maybe?
if you're on 260, downgrade to 256..


More information about the mythtv-users mailing list