[mythtv-users] Error opening jump program file buffer

Brian C. Huffman bhuffman at graze.net
Wed Dec 29 20:36:57 UTC 2010


When I go in and actually schedule the program, it works fine.

It used to take a second or two beyond the signal monitor saying 
"Locked" before it would start to play.  Now it's exiting out with error 
immediately upon saying "Locked" - I don't think it's waiting long 
enough for the HDPVR.

-b

On 12/29/2010 03:34 PM, Greg Oliver wrote:
> On Wed, Dec 29, 2010 at 2:30 PM, Brian C. Huffman<bhuffman at graze.net>  wrote:
>> All,
>>
>> I've been having a problem for a while now in the .24 branch that when I go
>> to change channels on my slave frontend on my HDPVR source, it fails and I
>> get a popup "Error opening jump program file buffer" and I see this on my
>> frontend:
>>
>> 2010-12-29 15:22:35.012 Clearing OpenGL painter cache.
>> 2010-12-29 15:22:43.439
>> RingBuf(/MediaFS/Video/Recordings/2006_20101229152243.mpg) Error:
>> OpenFile(): File too small (0B).
>> 2010-12-29 15:22:43.439 Player(0), Error: JumpToProgram's OpenFile failed
>> (card type: HDPVR).
>> 2010-12-29 15:22:43.439
>> LiveTVChain has 4 entries
>>    DUMMY: 8004 (15:22:06 to 15:22:15)
>>    HDPVR: 8004 (15:22:15 to 15:22:36) discontinuous
>>    DUMMY: 2006 (15:22:36 to 15:22:43) discontinuous
>> *  HDPVR: 2006 (15:22:43 to 16:00:00) discontinuous
>>
>> 2010-12-29 15:22:43.439 Player(0), Error: Unknown recorder error, exiting
>> decoder
>> 2010-12-29 15:22:43.675 TV: Attempting to change from WatchingLiveTV to None
>> 2010-12-29 15:22:43.677 VDPAU Painter: Clearing VDPAU painter cache.
>> 2010-12-29 15:22:43.680 MythPainter: 13 images not yet de-allocated.
>> 2010-12-29 15:22:43.912 Pulse: PulseAudio resume OK
>> 2010-12-29 15:22:45.686 TV: Changing from WatchingLiveTV to None
>> 2010-12-29 15:22:45.686 ScreenSaverX11Private: DPMS Reactivated 1
>> 2010-12-29 15:22:45.689 TV: Attempting to change from None to None
>> 2010-12-29 15:22:45.700 TV: Attempting to change from None to WatchingLiveTV
>> 2010-12-29 15:22:45.700 MythCoreContext: Connecting to backend server:
>> 192.168.10.20:6543 (try 1 of 1)
>> 2010-12-29 15:22:45.701 Using protocol version 63
>> 2010-12-29 15:22:45.778 MythCoreContext: Connecting to backend server:
>> 192.168.10.20:6543 (try 1 of 1)
>> 2010-12-29 15:22:45.779 Using protocol version 63
>> 2010-12-29 15:22:45.843 Spawning LiveTV Recorder -- begin
>> 2010-12-29 15:22:46.104 Spawning LiveTV Recorder -- end
>> 2010-12-29 15:22:46.117 We have a
>> playbackURL(/MediaFS/Video/Recordings/8004_20101229152246.mpg)&
>> cardtype(DUMMY)
>> 2010-12-29 15:22:46.117 We have a RingBuffer
>> 2010-12-29 15:22:46.364 playCtx, Error: Attempting to setup a player, but it
>> already exists.
>> 2010-12-29 15:22:46.364 TV Error: LiveTV not successfully started
>>
>> This is what I see on the backend:
>> 2010-12-29 15:28:37.135 adding: dorset.graze.net as a client (events: 0)
>> 2010-12-29 15:28:37.179 TVRec(2): Changing from None to WatchingLiveTV
>> 2010-12-29 15:28:37.222 TVRec(2): HW Tuner: 2->2
>> 2010-12-29 15:28:37.330 LoadFromScheduler(): Error, called from backend.
>> 2010-12-29 15:28:37.339 AutoExpire: CalcParams(): Max required Free Space:
>> 3.0 GB w/freq: 15 min
>> 2010-12-29 15:28:37.713 TVRec(2): Changing from WatchingLiveTV to None
>> 2010-12-29 15:28:37.861 Finished recording 40s On 4: channel 8004
>> 2010-12-29 15:28:43.363 Channel(/dev/video0) Error:
>> InitPictureAttribute(brightness): failed to query controls.
>>             eno: Bad file descriptor (9)
>>
>> I don't think this has been doing this until I updated to one of the fixes,
>> but I'm not 100% positive.  Does anyone have any insight into this?
> 0 byte file according to the logs.  Are you sure the hdpvr produced
> something?  Does the file have size on the filesystem?
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



More information about the mythtv-users mailing list