[mythtv-users] First Time VDPAU Attempt - Questions

julien trankkilou at gmail.com
Sat Feb 6 23:32:18 UTC 2010


mythfrontend --version should told u

#mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 23428M
MythTV Branch    : trunk
Network Protocol : 56
Library API      : 0.23.20100131-1
QT Version       : 4.5.3
Options compiled in:
 linux release using_oss using_alsa using_jack using_backend using_dvb using_firewire using_frontend using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_mheg


I have core 2 duo # 2.5 ghz and when decoding 1080i with temporal desinterlacer 2x my cpu is 96% IDLE

I think u should get the same result if your cpu is offload

regrds

Le 7 févr. 2010 à 00:22, Greg Hermsen a écrit :

> On Sat, Feb 6, 2010 at 2:40 AM, Richard Morton
> <richard.e.morton at gmail.com> wrote:
>> I am probably asking a stupid question, you do have the binary proprietary
>> nvidia drivers installed and enabled?
>> 
>> All I had to do was enable the driver and set the playback profile.
>> 
>> Look under system administration hardware drivers in gnome, not sure in xcfe
>> 
>> R
>> 
>> On 5 Feb 2010 23:57, "Greg Hermsen" <g.hermy15 at gmail.com> wrote:
>> 
>> Hi,
>> 
>> I'm running MythBuntu 9.10 and just purchased an Nvidia 9400GT card.
>> I looked at the VDPAU info at:
>> 
>>   http://www.mythtv.org/wiki/VDPAU
>> 
>> I think I need to recompile mythtv. It says...
>> 
>> MythTV
>> 
>>  ./configure --prefix=/usr --enable-proc-opt --disable-joystick-menu \
>>  --disable-firewire --disable-hdhomerun --disable-xvmcw --enable-xvmc-opengl
>> \
>>  --enable-vdpau  --disable-directfb --enable-opengl-vsync
>> 
>> MythPlugins
>> 
>>  ./configure --prefix=/usr --enable-opengl --enable-mytharchive \
>>  --disable-mythbrowser --disable-mythcontrols --disable-mythflix \
>>  --enable-mythgallery --disable-mythgame --enable-mythmusic
>> --disable-mythnews \
>>  --disable-mythphone --enable-mythvideo --disable-mythweather \
>>  --disable-mythzoneminder --disable-mythmovies
>> 
>> Can somebody give me a little direction?  The above two references
>> look like compile parameters I need to put in a file.  If so, where
>> should it be located, and what should it be called?  What is the
>> command to compile?
>> 
>> I'm running on a AMD 9350e quad core with 2 GB ram.  I'm using the
>> VDPAU Normal playback profile.  The video quality is very good, but my
>> four cores are running between 10-30% (concurrently).  I think VDPAU
>> must be running on my CPU instead of the 9400 GPU.  When I change my
>> playback profile to VDPAU High Quality, the video stutters.
>> 
>> Any help is apprieciatd.
>> 
>> Thanks,
>> Greg
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> 
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> 
>> 
> 
> I do have the proprietary Nvidia driver installed and enabled.  I'm
> not at my Myth system now, I think it was driver version 183 or 185.
> 
> I do have "VDPAU Normal" selected in the playback profile.  What I'm
> not sure of however, is the video processing  being offloaded to the
> GPU.  From what I read, it looks like I might need to recompile myth
> with an option that would enable mythtv to offload the graphics
> processing to the GPU.
> 
> I'm looking for:
> 1) confirmation that I do or do not need to recompile
> 2) if I need to recompile, how do I do that?
> 3) feedback on my CPU observation.  While running mythtv the for cores
> are typically at something like 5%, 22%, 13%, 30%
>    * Does this suggest that VDPAU processing is likely being done my
> CPU instead of my GPU?
> 
> Thanks,
> Greg
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100207/f55d0b46/attachment.htm>


More information about the mythtv-users mailing list