[mythtv-users] Problems with lirc on Mythbuntu 10.04

Jarod Wilson jarod at wilsonet.com
Wed Jun 16 13:42:38 UTC 2010


On Wed, Jun 16, 2010 at 6:26 AM, Brent Bolin <brent.bolin at gmail.com> wrote:
> On Tue, Jun 15, 2010 at 9:44 PM, Jarod Wilson <jarod at wilsonet.com> wrote:
>> On Tue, Jun 15, 2010 at 4:08 PM, Brent Bolin <brent.bolin at gmail.com> wrote:
>>> On Mon, Jun 14, 2010 at 9:01 PM, Brent Bolin <brent.bolin at gmail.com> wrote:
>>>> Been fighting with this all afternoon.  The default install seems to
>>>> work, but after updates lirc breaks with Mythtv .23-fixes
>>>>
>>>> When it works lsmod shows this -
>>>>
>>>> lsmod|grep lirc
>>>> lirc_mceusb            14054  1
>>>> lirc_dev               11302  3 lirc_mceusb
>>>>
>>>> When it's broken lsmod shows this -
>>>>
>>>> lsmod|grep lirc
>>>> lirc_mceusb            14054  0
>>>> lirc_dev               11302  1 lirc_mceusb
>>>>
>>>> Interesting that irw always shows input is working -
>>>>
>>>>  irw
>>>> 000000037ff07be0 00 Down mceusb
>>>> 000000037ff07be0 01 Down mceusb
>>>> 000000037ff07be0 00 Down mceusb
>>>> 000000037ff07be0 01 Down mceusb
>>>> 000000037ff07be1 00 Up mceusb
>>>> 000000037ff07be1 01 Up mceusb
>>>> 000000037ff07be1 00 Up mceusb
>>>> 000000037ff07be1 01 Up mceusb
>>>>
>>>> Need help.  Any input would be appreciated
>>>>
>>>>  lsb_release -a
>>>> No LSB modules are available.
>>>> Distributor ID: Ubuntu
>>>> Description:    Ubuntu 10.04 LTS
>>>> Release:        10.04
>>>> Codename:       lucid
>>>>
>>>
>>> This has turned into the upgrade from hell.
>>>
>>>
>>> root at brent:~# lsmod|grep lirc
>>> lirc_mceusb            12402  0
>>> lirc_dev                8884  1 lirc_mceusb
>>> root at brent:~# irw
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 01 Up mceusb
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 00 Up mceusb
>>> 000000037ff07be1 01 Up mceusb
>>>
>>> Above works, why doesn't myth?
>>
>> Make sure ~/.mythtv/lircrc has Up and not $somethingelse for that key.
>> If irw works, its a configuration issue w/mythtv, the core lirc bits
>> are working as they should.
>>
>
> Thanks Jarod for your reply.
>
> It's some kind of kernel module issue.  Surprised I didn't run into
> problems like this before.

Wait, so you have two different issues, one is that the driver isn't
binding to the receiver sometimes, and the other is that irw works,
but mythtv doesn't?

-- 
Jarod Wilson
jarod at wilsonet.com


More information about the mythtv-users mailing list