[mythtv-users] Frontend won't start after upgrading to 0.23-fixes

Harry Devine lifter89 at comcast.net
Mon May 10 23:49:02 UTC 2010


Michael T. Dean wrote:
> On 05/10/2010 07:37 PM, Harry Devine wrote:
>> My Mythbuntu install upgraded my mythbuntu-repos today and when 
>> reconfigured it, I let it pick 0.23-fixes.  It installed what it 
>> needed to, and I ran mythtv-setup to allow the database schema to get 
>> upgraded from1244 to 1254.  My backend is running (version 24509), 
>> but when I try and start my frontend, I get the following in the logs:
>>
>> Starting mythfrontend.real..
>> 2010-05-10 19:31:33.461 mythfrontend version: 
>> branches/release-0-23-fixes [24509] www.mythtv.org
>> 2010-05-10 19:31:33.461 Using runtime prefix = /usr
>> 2010-05-10 19:31:33.461 Using configuration directory = 
>> /home/hdevine/.mythtv
>> 2010-05-10 19:31:34.152 Empty LocalHostName.
>> 2010-05-10 19:31:34.153 Using localhost value of hdevine-desktop
>> 2010-05-10 19:31:34.166 New DB connection, total: 1
>> 2010-05-10 19:31:44.183 Connected to database 'mythconverg' at host: 
>> 192.168.1.200
>> 2010-05-10 19:31:44.184 Closing DB connection named 'DBManager0'
>> 2010-05-10 19:31:44.206 ScreenSaverX11Private: Gnome screen saver 
>> support enabled
>> 2010-05-10 19:31:44.208 DPMS is active.
>> 2010-05-10 19:31:44.211 Primary screen: 0.
>> 2010-05-10 19:31:54.222 Connected to database 'mythconverg' at host: 
>> 192.168.1.200
>> 2010-05-10 19:31:54.225 Using screen 0, 1280x720 at 0,0
>> 2010-05-10 19:31:54.250 Desktop video mode: 1280x720 59.8552 Hz
>> 2010-05-10 19:31:54.278 MythUI Image Cache size set to 20971520 bytes
>> 2010-05-10 19:31:54.318 Enabled verbose msgs:  important general
>> 2010-05-10 19:31:54.327 Primary screen: 0.
>> 2010-05-10 19:31:54.328 Using screen 0, 1280x720 at 0,0
>> 2010-05-10 19:31:54.330 Using theme base resolution of 1280x720
>> 2010-05-10 19:31:54.340 LIRC: Successfully initialized '/dev/lircd' 
>> using '/home/hdevine/.mythtv/lircrc' config
>> 2010-05-10 19:31:54.340 JoystickMenuThread Error: Joystick disabled - 
>> Failed to read /home/hdevine/.mythtv/joystickmenurc
>> 2010-05-10 19:31:54.401 Using Frameless Window
>> 2010-05-10 19:31:54.401 Using Full Screen Window
>> 2010-05-10 19:31:54.564 Using the Qt painter
>> 2010-05-10 19:31:54.676 XMLParseBase: Loaded base theme from 
>> '/usr/share/mythtv/themes/metallurgy/base.xml'
>> 2010-05-10 19:31:54.723 XMLParseBase: Loaded base theme from 
>> '/usr/share/mythtv/themes/default-wide/base.xml'
>> 2010-05-10 19:31:54.735 XMLParseBase: Loaded base theme from 
>> '/usr/share/mythtv/themes/default/base.xml'
>> 2010-05-10 19:31:54.741 New DB connection, total: 2
>> 2010-05-10 19:31:54.743 New DB connection, total: 3
>> 2010-05-10 19:31:54.745 Current MythTV Schema Version (DBSchemaVer): 
>> 1254
>> 2010-05-10 19:31:55.062 Registering Internal as a media playback plugin.
>> 2010-05-10 19:31:55.089 Cannot load language en_us for module 
>> mytharchive
>> 2010-05-10 19:31:55.117 MediaMonitorUnix::AddDevice() - empty device 
>> path.
>> 2010-05-10 19:31:55.117 MediaMonitorUnix::AddDevice() - empty device 
>> path.
>> 2010-05-10 19:31:55.118 MediaMonitorUnix::AddDevice() - empty device 
>> path.
>> 2010-05-10 19:31:55.118 MonitorRegisterExtensions(0x100, gif,jpg,png)
>> 2010-05-10 19:31:55.118 Cannot load language en_us for module 
>> mythgallery
>> 2010-05-10 19:31:55.120 Cannot load language en_us for module mythmovies
>> 2010-05-10 19:31:55.136 Current MythMusic Schema Version 
>> (MusicDBSchemaVer): 1017
>> 2010-05-10 19:31:55.172 MonitorRegisterExtensions(0x40, 
>> mp3,mp2,ogg,oga,flac,wma,wav,ac3,oma,omg,atp,ra,dts,aac,m4a,aa3,tta,mka,aiff,swa,wv) 
>>
>> 2010-05-10 19:31:55.177 Cannot load language en_us for module mythmusic
>> 2010-05-10 19:31:55.184 Current MythVideo Schema Version 
>> (mythvideo.DBSchemaVer): 1028
>> 2010-05-10 19:31:55.184 MythVideo database schema is old. Waiting to 
>> see if DB is being upgraded.
>> 2010-05-10 19:31:56.184 New DB connection, total: 4
>> 2010-05-10 19:32:04.748 Connected to database 'mythconverg' at host: 
>> 192.168.1.200
>> 2010-05-10 19:32:14.757 Connected to database 'mythconverg' at host: 
>> 192.168.1.200
>> 2010-05-10 19:32:24.765 Connected to database 'mythconverg' at host: 
>> 192.168.1.200
>> 2010-05-10 19:32:24.774 Current MythVideo Schema Version 
>> (mythvideo.DBSchemaVer): 1028
>> 2010-05-10 19:32:24.774 Timed out waiting.
>> 2010-05-10 19:32:24.798 Backing up database with script: 
>> '/usr/share/mythtv/mythconverg_backup.pl'
>> 2010-05-10 19:32:38.947 Database Backup complete.
>> 2010-05-10 19:32:38.948 Backed up database to file: 
>> '/storage/recordings/mythconverg-1254-20100510193224.sql.gz'
>> QProcess: Destroyed while process is still running.
>> ICE default IO error handler doing an exit(), pid = 4141, errno = 32
>>
>> It has done this 3 times so far.  I get the background window on the 
>> screen, then it goes away.  Any ideas on how I can fix this?
>
> sudo rm /home/mythtv/.ICEAuthority
>
> (or for whatever user is running the GUI apps)--or just remove it from 
> all user directories.  It's a broken system configuration (not MythTV 
> related).
>
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>
Thanks Mike!  That was it.  I've had to do that before on one of my 
systems at work, and I never gave it a thought that I had to remove it 
here.  Oh well, you learn something new every day!

Thanks again!
Harry



More information about the mythtv-users mailing list