[mythtv-users] mythbuntu 9.10 lirc irblaster serial homebrew hardware.comf

Björn Lundin b.f.lundin at gmail.com
Fri May 21 15:51:48 UTC 2010


> I keep hating hardware.conf more and more. If you only have one
> device, set up everything under one of the namespaces -- TRANSMITTER
> or REMOTE, but don't split things up between both. And double-check
> that _DEVICE= option.

Ok, DEVICE:

bnl at ibm:~/download/lirc-0.8.6$ ls -la /dev/lir*
crw-r--r-- 1 root root 61, 0 2010-05-19 22:22 /dev/lirc
crw-rw---- 1 root root 61, 0 2010-05-19 22:48 /dev/lirc0
lrwxrwxrwx 1 root root    19 2010-05-19 22:14 /dev/lircd -> /var/run/lirc/lircd
bnl at ibm:~/download/lirc-0.8.6$

Yes, I have both. I guess one is from my deb-installs and the other
from the source-code installation.
Neither of them works.


bnl at ibm:~/download/lirc-0.8.6$ cat /etc/lirc/hardware.conf
#Chosen IR Transmitter
TRANSMITTER="Homebrew"
TRANSMITTER_MODULES="lirc_serial"
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE="/dev/lirc"
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF="/etc/lirc/lircd.conf"
TRANSMITTER_LIRCD_ARGS=""


I opted for the TRANSMITTER prefix, but :-(

bnl at ibm:~/download/lirc-0.8.6$ irsend -d /var/run/lirc/lircd SEND_ONCE
Dilog_DT_358 6
irsend: command failed: SEND_ONCE Dilog_DT_358 6
irsend: transmission failed
bnl at ibm:~/download/lirc-0.8.6$ irsend LIST "" ""
irsend: Dilog_DT_358
bnl at ibm:~/download/lirc-0.8.6$


I have the modules loaded
bnl at ibm:~/download/lirc-0.8.6$ lsmod | grep lir
lirc_serial            12308  0
lirc_dev               10804  1 lirc_serial


and the options are
bnl at ibm:~/download/lirc-0.8.6$ cat /etc/modprobe.d/lirc-serial.conf
#COM1 equivalent, /dev/ttyS0
options lirc_serial irq=4 io=0x3f8
bnl at ibm:~/download/lirc-0.8.6$


Strange thing, I get the same result if I put the tranceiver on ttyS1
instead of ttyS0...


-- 
/Björn


More information about the mythtv-users mailing list