[mythtv-users] HDPVR Causing Backend to Hard Freeze

Greg greg12866 at nycap.rr.com
Mon May 24 16:41:56 UTC 2010


On 05/24/2010 12:16 PM, Jason Sharpe wrote:
>
>
>     Message: 18
>     Date: Mon, 24 May 2010 11:36:17 -0400
>     From: Greg <greg12866 at nycap.rr.com <mailto:greg12866 at nycap.rr.com>>
>     Subject: Re: [mythtv-users] HDPVR Causing Backend to Hard Freeze
>     To: Discussion about mythtv <mythtv-users at mythtv.org
>     <mailto:mythtv-users at mythtv.org>>
>     Message-ID: <4BFA9CF1.5040204 at nycap.rr.com
>     <mailto:4BFA9CF1.5040204 at nycap.rr.com>>
>     Content-Type: text/plain; charset="iso-8859-1"; Format="flowed"
>
>     On 05/24/2010 09:47 AM, Jason Sharpe wrote:
>     >
>     >     Date: Sun, 23 May 2010 23:43:35 -0500
>     >     From: <mythtv.list at gmail.com <mailto:mythtv.list at gmail.com>
>     <mailto:mythtv.list at gmail.com <mailto:mythtv.list at gmail.com>>>
>     >     Subject: [mythtv-users] HDPVR Causing Backend to Hard Freeze
>     >     To: mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>     <mailto:mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>>
>     >     Message-ID:
>     > <AANLkTik9Zpyq8ZGeHXcEEKNrF8ZOXOqSYFqqVJguPivq at mail.gmail.com
>     <mailto:AANLkTik9Zpyq8ZGeHXcEEKNrF8ZOXOqSYFqqVJguPivq at mail.gmail.com>
>     >
>     <mailto:AANLkTik9Zpyq8ZGeHXcEEKNrF8ZOXOqSYFqqVJguPivq at mail.gmail.com
>     <mailto:AANLkTik9Zpyq8ZGeHXcEEKNrF8ZOXOqSYFqqVJguPivq at mail.gmail.com>>>
>     >     Content-Type: text/plain; charset="iso-8859-1"
>     >
>     >     Hello,
>     >
>     >     I have been fighting this issue for a days now and I wanted to
>     >     throw this
>     >     out there to see if anyone else has seen/heard of anything like
>     >     this. I can
>     >     recreate the issue over and over but I am not sure what is
>     causing it.
>     >
>     >     When one recording is ending on a tuner and another is beginning
>     >     on my HDPVR
>     >     my whole backend hard freezes requiring a push of the reset
>     button
>     >     for the
>     >     PC to come back up.
>     >
>     >     In Other Words:
>     >     Tuner 1: HD Homerun Records from 09:00 - 10:00
>     >     Tuner 2: HDPVR Has a show starting at 10:00
>     >
>     >     At 09:59 when the backend should start recording from the HDPVR
>     >     the backend
>     >     hard freezes.
>     >
>     >     Using that example above, if the HDPVR starts to record at 09:30
>     >     everything
>     >     is fine. It is only when 1 show is ending and another is
>     beginning
>     >     on the
>     >     HDPVR.
>     >
>     >     I can record from each tuner just fine for multiple shows
>     back to
>     >     back on
>     >     the same tuner without issue, so the tuners work.
>     >
>     >     Here is the strange thing, the other way around, there is no
>     freezing.
>     >
>     >     Meaning:
>     >     Tuner 1: HDPVR Records from 09:00 - 10:00
>     >     Tuner 2: HD Homerun Has a show starting at 10:00
>     >
>     >     In that senerio, everything works just fine.
>     >
>     >     I have elimitated the HD Homerun as the source of the problem by
>     >     trying a
>     >     pcHDTV HD-3000 instead, still freezes.
>     >
>     >     Details:
>     >     HD Homerun using Tuner 0 (Over the Air ATSC)
>     >     HDPVR and a Dishnetwork ViP 211k receiver (Component and SPDIF)
>     >
>     >     Note: IR blasting is done via a homebrew serial blaster, I am
>     >     _not_ using
>     >     the HDPVR for blasting.
>     >
>     >     Both the HD Homerun and the HDPVR are running the latest
>     firmware.
>     >     I was
>     >     going to downgrade the firmware in the HDPVR, but I read
>     that the
>     >     previous
>     >     version had its own problems.
>     >
>     >     I am running Mythdora 12.23, mythbackend version:
>     tags/release-0-23
>     >     [0.23-1.md12 (r24509).
>     >
>     >     The backend log isn't much help, since when it freezes it can't
>     >     write to it,
>     >     heh (HW Tuner 44 is the HDPVR)
>     >
>     >     2010-05-23 21:58:00.784 Reschedule requested for id 0.
>     >     2010-05-23 21:58:01.977 Scheduled 781 items in 1.2 = 0.01
>     match +
>     >     1.17 place
>     >     2010-05-23 21:58:01.991 scheduler: Scheduled items:
>     Scheduled 781
>     >     items in
>     >     1.2 = 0.01 match + 1.17 place
>     >     2010-05-23 21:58:29.861 TVRec(44): ASK_RECORDING 44 29 0 0
>     >     2010-05-23 21:59:01.227 ProgramInfo(): Updated pathname '':'' ->
>     >     '5389_20100523215900.mpg'
>     >     2010-05-23 21:59:01.346 TVRec(44): Changing from None to
>     RecordingOnly
>     >     2010-05-23 21:59:01.358 TVRec(44): HW Tuner: 44->44
>     >     2010-05-23 21:59:02.471 ret_pid(0) child(11739) status(0x0)
>     >     2010-05-23 21:59:03.484 ret_pid(0) child(11739) status(0x0)
>     >     2010-05-23 21:59:04.501 ret_pid(0) child(11739) status(0x0)
>     >     2010-05-23 21:59:05.519 ret_pid(0) child(11739) status(0x0)
>     >     2010-05-23 21:59:06.536 ret_pid(0) child(11739) status(0x0)
>     >
>     >     The next line of the log is the backend starting after I had to
>     >     push the
>     >     reset button.
>     >
>     >     I am at my wits end, any ideas?
>     >
>     >     Thanks in advance for any help.
>     >
>     >
>     >
>     > So I spent some more time working on the issue this morning.
>     >
>     > I downgraded the firmware of the HDPVR, no change, still hangs as
>     > described.
>     >
>     > I reloaded the newest firmware of the HDPVR into it and changed the
>     > USB port it was plugged into making sure it was on a different
>     bus, no
>     > change, still hangs as described.
>     >
>     >
>     >
>     > _______________________________________________
>     > mythtv-users mailing list
>     > mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>     > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>     >
>     Most people with this problem add a sleep to their channel changing
>     script...Search this list for hdpvr channel script... I would
>     guess that
>     is your problem also..
>
>
>
> Thanks for the reply.
>
> I had read that when I got the HDPVR, so since day 1 with the HDPVR I 
> have had a 3 sec sleep at the end of the script. I just checked my 
> script and confirmed the 3.0 sec sleep at the end.
>
> Any other ideas?
>
>
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>    
No sorry, I still believe it's a sleep issue.
Did you try asking these questions on the Mythdora forums?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100524/8aa61b1f/attachment.htm>


More information about the mythtv-users mailing list