[mythtv-users] Transcoding SD MPEG2 to H.264---recommendations?

f-myth-users at media.mit.edu f-myth-users at media.mit.edu
Mon Nov 29 08:52:33 UTC 2010


    > Date: Mon, 29 Nov 2010 09:36:51 +1100
    > From: Christopher Kerr <mythtv at theseekerr.com>

    > I'm not doing this yet, but I'm planning to get such a thing going
    > over the next few weeks to help manage the endless episodes of "Escape
    > to the Country" and "Bargain Hunt" that are clogging up my harddrive.

    > I plan to use HandbrakeCLI with the Transcode Wrapper Stub on the wiki.

I had very bad results with Handbrake in a test yesterday---see below.

    > Transcode times vary pretty wildly depending on the complexity of the
    > job, but as a datapoint:

What args are you using to Handbrake?  Or are you using something like
ffmpeg directly?

    > I'm using an i5 750 (quad core, currently overclocked to 3.8GHz per
    > core, stock is 2.66) with 4GB of RAM.

    > A high profile encode of PAL DTV material, using deinterlacing and
    > denoising, runs at 2-3 times realtime using all 4 cores.

    > If you trade off some filesize for speed, a more normal encode might
    > run at 4-5 times realtime (or about 1.5 times realtime if run on a
    > single core)

    > At the best end of things, the low-complexity low-resolution iPhone
    > preset with denoising runs at about 6-8 times realtime (ie. a 2 hour
    > film takes 15-20 minutes)

Those times look good; I tried a Handbrake test with PVR-250 input
(interlaced NTSC, 720x480) on an Athlon 64 5400+ (2.8GHz?) and it ran
at about real-time speed using its default settings but no auto-crop,
and using 1.5 of the 2 cores.  (Apparently, it couldn't keep the other
half of the second core busy.)

However---the result was unusable.  The activity log was crammed full
of "audio 192 time went backwards 0 ms, dropped 1 frames" and "video
time didn't advance - dropped 1 frames" lines, and about halfway
through the transcode, it suddenly went from claiming it had 20
minutes to go, to done.  (It also said "sync: got 26887 frames, 60691
expected", which might explain a thing or two.)  And the result, as you
might expect, was a jumpy mess.

I have no idea why this didn't work.  I'd have thought that the mpeg
file produced by a PVR-250 seeing baseband NTSC from an STB would be
about as easy as you could get.  I do have VBI CC enabled; I wonder if
that extra info is confusing Handbrake.  Searching for those error
messages with or without PVR and other likely terms hasn't yielded
much that's usable, alas.

(The Handbrake version was "svn3686", which is what you get if you're
running Ubuntu 9.10  and add ppa:stebbins/handbrake-snapshots.  I have
no idea if this is just a bad version or what.)

Didn't matter whether cropping was on or off, or whether I used the
default decomb or switched to fast deinterlace.

P.S.  Other issue is how I'm going to display deinterlaced transcoded
stuff on my Sony analog CRT; can any VDPAU-capable card output interlaced
content?  I seem to recall asking exactly this question a year or two
ago, but can't find it and can't remember the answer...  I'm guessing
that anything with an S-Video output is also outputting interlaced,
but...


More information about the mythtv-users mailing list