[mythtv-users] Multiple LIRC Devices Causing Problems with HD-PVR Blaster on F14

Jarod Wilson jarod at wilsonet.com
Thu Feb 17 18:08:25 UTC 2011


On Feb 14, 2011, at 5:26 PM, John Welch wrote:

> On Mon, Feb 14, 2011 at 11:15 AM, Jarod Wilson <jarod at wilsonet.com> wrote:
>> On Feb 14, 2011, at 9:51 AM, John Welch wrote:
...
>>> Thanks for the reply Jarod.  I guess what I should have said as far as
>>> it previously working is that the HD-PVR blaster was always
>>> /dev/lirc0.  I don't know what device was being assigned to the
>>> HD-3000, or if it was even loading.  As I said, I'm not using anything
>>> with LIRC and the HD-3000 so would never have even bothered to look.
>> 
>> Okay, my guess is that there was nothing loading for the HD-3000
>> previously. It might actually be lirc_zilog that is binding to it now,
>> if I'm thinking clearly...

Nope, the cx88xx driver has some form of integrated IR support, which in
the latest kernels, loads up ir-lirc-codec, which in turn means you
now get an lirc device for the cx88xx driver's IR.

This in an appropriate /etc/modprobe.d/*.conf file would prevent the
creation of the IR devices for your HD-3000:

options cx88xx disable_ir=1

> I found that I do have a 'modprobe' line in my rc.local file for the
> lirc_zilog module.  Can change it to
> /etc/sysconfig/modules/lirc.modules if that helps the problem.

It might, it might not. I suspect there would still be a driver load
race, so disabling IR on the HD-3000 or going the route Ramin suggested
are better options.

Will address your follow-up message about HDPVR instability in a sec...

-- 
Jarod Wilson
jarod at wilsonet.com





More information about the mythtv-users mailing list