[mythtv-users] Suggested bitrate for transcoding HD Mpeg 2 to Mpeg 4

Neil Salstrom salstrom at gmail.com
Fri Jun 3 04:58:31 UTC 2011


On Thu, Jun 2, 2011 at 6:17 PM, Neil Salstrom <salstrom at gmail.com> wrote:
(snip)

>    Stream #0.0[0x31]: Video: mpeg2video, yuv420p, 1280x720 [PAR 1:1
> DAR 16:9], 38800 kb/s, 59.96 fps, 59.94 tbr, 90k tbn, 119.88 tbc
>    Stream #0.1[0x34](eng): Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
> File for preset 'hq' not found
> Transcode failed
>
> mythtv at htpc:~$
>
> Any ideas?  I did this by file name because I was not sure what the
> job number was.  Can you give any insight as to what may be going on?
>
> Thanks!!!
>

Ok, talking to myself here... Just in case anyone else had this same
issue.  I'm using Debian Stable (Squeeze).  The ffmpeg in Debian
Multimedia does not have a 'hq' preset.  In the script I changed the
'hq' callout to 'slow' and it's working.  Here is my list of potential
presets:

htpc:/home/mythtv# find /usr -iname '*.ffpreset'
/usr/share/ffmpeg/libx264-medium.ffpreset
/usr/share/ffmpeg/libx264-lossless_slower.ffpreset
/usr/share/ffmpeg/libx264-ipod640.ffpreset
/usr/share/ffmpeg/libx264-fast_firstpass.ffpreset
/usr/share/ffmpeg/libx264-faster.ffpreset
/usr/share/ffmpeg/libx264-veryfast.ffpreset
/usr/share/ffmpeg/libx264-medium_firstpass.ffpreset
/usr/share/ffmpeg/libx264-slower_firstpass.ffpreset
/usr/share/ffmpeg/libx264-superfast_firstpass.ffpreset
/usr/share/ffmpeg/libx264-veryslow.ffpreset
/usr/share/ffmpeg/libx264-fast.ffpreset
/usr/share/ffmpeg/libx264-lossless_fast.ffpreset
/usr/share/ffmpeg/libx264-ipod320.ffpreset
/usr/share/ffmpeg/libx264-placebo_firstpass.ffpreset
/usr/share/ffmpeg/libx264-baseline.ffpreset
/usr/share/ffmpeg/libx264-superfast.ffpreset
/usr/share/ffmpeg/libx264-slow.ffpreset
/usr/share/ffmpeg/libx264-veryslow_firstpass.ffpreset
/usr/share/ffmpeg/libx264-veryfast_firstpass.ffpreset
/usr/share/ffmpeg/libx264-lossless_slow.ffpreset
/usr/share/ffmpeg/libx264-slow_firstpass.ffpreset
/usr/share/ffmpeg/libx264-main.ffpreset
/usr/share/ffmpeg/libx264-lossless_max.ffpreset
/usr/share/ffmpeg/libx264-slower.ffpreset
/usr/share/ffmpeg/libx264-placebo.ffpreset
/usr/share/ffmpeg/libx264-lossless_medium.ffpreset
/usr/share/ffmpeg/libx264-ultrafast.ffpreset
/usr/share/ffmpeg/libx264-lossless_ultrafast.ffpreset
/usr/share/ffmpeg/libx264-faster_firstpass.ffpreset
/usr/share/ffmpeg/libx264-ultrafast_firstpass.ffpreset

At this point I'm not sure the differnce between them but I picked
slow just to test.  I've not watched the resulting file but it seems
to be working now.

Neil


More information about the mythtv-users mailing list