[mythtv-users] Question while trying to setup a HDPVR

Jarod Wilson jarod at wilsonet.com
Fri Jun 10 17:11:53 UTC 2011


On Jun 10, 2011, at 12:17 PM, Adam Jimerson wrote:

> Thank your for your reply, I am currently not at my Mythbox but I will try that out later today,

Please note: this list has a no-top-posting policy.


> I only have to worry about the rx thread in zilog only if I want the HDPVR to receive from its IR receiver correct.

The rx thread gets created even if you're not using rx, unless you pass
in the tx_only=1 option.


> On Fri, Jun 10, 2011 at 9:22 AM, Jarod Wilson <jarod at wilsonet.com> wrote:
> On Jun 10, 2011, at 12:41 AM, Adam Jimerson wrote:
> 
> > Ok so I just bought a HDPVR to connect my satellite box to my Mythbox,
> > so far everything is going well, I was able to cat /dev/video0 to a .ts
> > file and had both video and sound with out having to update any firmware
> > on the PVR (on the bottom of the box it says that it is a "Rev F2").  I
> > got if setup in myth for the most part but the trouble I have is during
> > trying to set up the IR Transmitter and have several questions...
> >
> > 1. Following the directions on the Myth's wiki for the device step for
> > for adding the HD-PVR to MythTV says "Important Note: You must set a
> > channel change script for the HD-PVR to work properly. If you don't care
> > about channel changes, you can set it to /bin/true, but there absolutely
> > must be a channel change script defined."  I would like to have myth be
> > able to change the channel on my satellite box but what scripts is it
> > referring to?
> 
> There are multiple channel changing scripts in the mythtv wiki, any
> that are for lirc can be adapted to work. There's also one linked to at
> another location I'll link to later on in this reply. :)
> 
> 
> > 2. I have Lirc and the Lirc utilities package installed on my distro
> > (Arch Linux) and upon starting lircd it sees the HD-PVR but I don't see
> > a hardware.conf anywhere on my system, I tried using locate but it seems
> > to not exists is this a problem?
> 
> hardware.conf is a not part of upstream lirc, despite what legions of
> Ubuntu users would lead you believe. It doesn't exist on most other
> distributions outside of Debian derivatives. All it does is feed params
> to your lirc initscript though. Fedora uses /etc/sysconfig/lirc to do
> similar, not entirely sure about other distros.
> 
> Adding a standard lirc daemon config file that lircd itself reads is
> on my TODO list, so we *do* have a common centralized config, rather
> than every distribution rolling its own.
> 
> 
> > 3. When checking dmesg the output of lirc_zilog is confusing:
> >
> > [107355.768180] lirc_dev: IR Remote Control driver registered, major 249
> >
> > [107355.768685] lirc_zilog: module is from the staging directory, the
> > quality is unknown, you have been warned.
> > [107355.769772] lirc_zilog: Zilog/Hauppauge IR driver initializing
> >
> > [107355.770554] lirc_zilog: probing IR Rx on Hauppage HD PVR I2C (i2c-6)
> >
> > [107355.770560] lirc_zilog: probe of IR Rx on Hauppage HD PVR I2C
> > (i2c-6) done. Waiting on IR Tx.
> > [107355.770568] lirc_zilog: probing IR Tx on Hauppage HD PVR I2C (i2c-6)
> >
> > 107355.770711] i2c i2c-6: lirc_dev: driver lirc_zilog registered at
> > minor = 0
> > [107355.795975] lirc_zilog: firmware haup-ir-blaster.bin not available
> > (-2)
> 
> You're missing the necessary binary blaster index-to-signal-waveform
> data blob that has to be loaded into the driver for it to be able to
> actually transmit.
> 
> 
> > [107355.796070] lirc_zilog: ir_probe: probing IR Tx on Hauppage HD PVR
> > I2C (i2c-6) failed with -2
> > [107355.796083] Zilog/Hauppauge i2c IR: probe of 6-0070 failed with
> > error -2
> > [107355.796126] lirc_zilog: initialization complete
> >
> > I take it by the fact that I only have a /dev/licrd and no /dev/lirc0
> > that it failed?  If so is this a problem with the firmware on the PVR or
> > a issue with the drivers for the IR Transmitter I didn't compile them
> > manually just using the ones packaged by Arch (I didn't see any
> > instructions on the wiki for it...)
> 
> Read up here:
> 
> http://wilsonet.com/?p=40
> 
> Start at "Either way, you still need a firmware image..." though, since
> the earlier bits are all irrelevant, now that the patches to enable the
> IR part on the hdpvr are all upstream.
> 
> Also, watch out for a zilog rx thread pegging your cpu, there's a bug
> in certain eras of lirc_zilog code, for which I just sent a patch upstream
> yesterday. Optionally, if you're not using the rx bit, load lirc_zilog
> with the module parameter tx_only=1.
> 
> --
> Jarod Wilson
> jarod at wilsonet.com
> 
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

-- 
Jarod Wilson
jarod at wilsonet.com





More information about the mythtv-users mailing list