[mythtv-users] UK - my listings are disappearing

Nick Morrott knowledgejunkie at gmail.com
Wed Nov 2 15:34:50 UTC 2011


On 2 November 2011 15:08, Mike Perkins <mikep at randomtraveller.org.uk> wrote:
> I have realised that I am no longer getting listings updates from the Radio
> Times feed (via xmltv). I have tried to fault find the problem but without much
> success.
>
> If I run tv_grab_uk_rt manually it appears to succeed, but the output file only
> contains partial schedule data. If I then attempt to load this using
> mythfilldatabase /nothing/ changes, probably because the data replicates what is
> already there from when it worked.
>
> I can't ping xmltv.radiotimes.com, which means I can't even check if the GETs
> are being intercepted by my firewall.
>
> If I attempt to web browse to xmltv.radiotimes.com I get a web page which notes:
>
>
> Old RadioTimes.com
>
> Please note we are only updating listings on this site until 30th Sept
>
>
> Any ideas?

The grabber is working fine here, and the Radio Times currently
carries data out to 2011-11-16. No issues are reported on the nightly
XMLTV validator either:

http://debian.crustynet.org.uk/~xmltv-tester/squeeze/release/

Run the grabber manually with debugging enabled (pass the --debug
option) and capture the debug output to STDERR. This should show what
is happening and reveal whether fresh data is being received from
radiotimes.com or whether cached data is being used (which will
eventually run out).

Cheers,
Nick

-- 
Nick Morrott

MythTV Official wiki: http://mythtv.org/wiki/
MythTV users list archive: http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin


More information about the mythtv-users mailing list