[mythtv-users] LiveTV problem

R. G. Newbury newbury at mandamus.org
Mon Nov 21 15:15:10 UTC 2011


On 11/21/2011 02:07 AM, Stefan D wrote:
> On Mon, Nov 21, 2011 at 4:34 AM, R. G. Newbury<newbury at mandamus.org>  wrote:
>
>> On 11/20/2011 03:57 PM, Kris B. wrote:
>>> On Sunday, November 20, 2011 9:42 PM, "Stefan D"
>>> <raptorjr08 at gmail.com>   wrote:
>>>
>>>     Well, i continue to report problems.
>>>     I'm using LiveTV, i know that it's not very popular and no dev
>>>     is using it. But i'm thinking that this could maybe be a
>>>     problem to others too.
>>>     It started when i was tuning to a channel i thought i had
>>>     access to, but obviously didn't. In the log attached following
>>>     things is happening.
>>>     1. First i tune to a channel that i have access to, works
>>>     fine.
>>>     2. Then i tune to this unavaliable channel, Myth fails after a
>>>     while unable to open program buffer.
>>>     3. Then i start LiveTV again and Myth tunes to the last
>>>     working channel, the channel that worked in step 1. This now
>>>     fails.
>>>     4. I try to start LiveTV again, still same channel as in step
>>>     1, still fails.
>>>     5. I restart the frontend, and now Myth is able to tune to the
>>>     channel in step 1 again.
>>>     So the problem is that when Myth fails to tune to a channel it
>>>     can't tune to a valid channel unless the frontend is
>>>     restarted.
>>>     Maybe this could be a issue to others too that don't use
>>>     LiveTV?
>>>
>>>
>>> This happens to me, too, when a channel is flaky.  The workaround
>>> (other than don't have flaky channels) is to go into mythweb(but
>>> maybe I am wrong) or mythtv-setup and change the last channel you
>>> were on to a different channel that works.  Sometimes I can when
>>> trying to go back into LiveTV put on a differnet channel really
>>> quick (lets say 45.1 was the bad channel, if I type 2.1 as it is
>>> loading) and not have to go through the hassle of
>>> mythweb/mythtv-setup...
>>
>> Here is a rather quick and dirty script *WHICH MESSES DIRECTLY WITH YOUR
>> DATABASE*. It re-sets all your tuners to a 'good' channel number. Exit
>> LiveTV and run from this from a console. I call it 'startchan-fix' The
>> dangerous lines have been commented out. If you cannot exit LiveTV then
>> you will have to kill the frontend, and then run the script before
>> re-starting the frontend.
>> Adjust as required for your user, password and mythtv database name.
>>
>> However this script messes with your database and it may be dangerous to
>> your sanity or even the WAF score in your house. The dog may bark at you
>> and your hair may turn grey, if it has not already. YMMV UAYOR.
>>
>> **********************
>> #!/bin/bash
>> Channel1=42
>> Channel2=102_1
>> #echo 'update cardinput set startchan = '$Channel1' where cardid = '1'>
>> /var/tmp/startchanfix
>> #echo 'update cardinput set startchan = '$Channel2' where cardid = '3'>
>> /var/tmp/startchanfix
>>
>> #echo "Setting Channel to   "$Channel1"    on Tuner  1"
>> #echo "Setting Channel to   "$Channel2"    on Tuner  3"
>> #mysql -u mythtv -pmythtv mythconverg<  /var/tmp/startchanfix
>> #rm -f /var/tmp/startchanfix
>>
>> *********************
>>
>>
>> Geoff
>>
>>
>>
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://www.mythtv.org/mailman/listinfo/mythtv-users
>>
>
> Thank you but i don't think that would help. Myth is already on a good
> channel, but since the previous tune failed, Myth can't tune to the good
> channel unless i restart the frontend.
>
> Lets say channel 1 is good, if i try to tune to the bad channel 10, channel
> 1 will fail afterwards. Doesn't matter that it was a good channel before
> because something is messed up in Myth that makes it impossible to tune.
> Maybe it would work to tune to another good channel instead of restarting
> Myth, haven't tried that yet. But a script the sets a specific channel
> won't work because it all depends on which channel i was on before Myth
> tried to tune to the bad channel.


I suggest that you try the script. My experience was *exactly* the same 
as yours. The system would NOT go back. A bad channel was a complete 
dead end. I assume that the failed tuning process leaves some digital 
trail of itself. The system *tries* to tune to the settings it has, 
before switching to the new parameters, and fails, since those settings 
are the bad ones. I cannot recall exactly, but istr that it did not 
matter which good channel I tried to change to, the change failed.

I do not know if the code writes the 'startchan' data as it begins to 
tune to the channel, or only after tuning has been completed, and some 
status check is done. I suspect the first, as there is no apparent 
escape scheme from a failed attempt at tuning. (If someone wrote the 
code to check, I would assume that there would be some exception handler 
rather than the dead hangup we get.  Enhancement request anyone?)

Geoff









More information about the mythtv-users mailing list