[mythtv-users] backend segfault on 0.21, probably fixed already in new releases?

David Whyte david.whyte at gmail.com
Tue Nov 29 11:45:12 UTC 2011


Hi,

I experienced my first backend segfault in a long time just yesterday
when I got a phone call from my parents saying their mythTV had
broken.

Upon logging in, I could see the logs weren't being written to, with
the last entries as follows (until my restart at 20:16):

2011-11-28 18:56:02.030 Started recording: RSPCA Animal Rescue:
channel 1007 on cardid 10, sourceid 1
2011-11-28 18:56:02.037 scheduler: Started recording: RSPCA Animal
Rescue: channel 1007 on cardid 10, sourceid 1
2011-11-28 18:56:02.465 Program #1344 not found in PAT!
Program Association Table
 PSIP tableID(0x0) length(25) extension(0x400)
      version(2) current(1) section(0) last_section(0)
         tsid: 1024
 programCount: 4
  program number     0 has PID 0x  10   data  0x 0 0x 0 0xe0 0x10
  program number  1025 has PID 0x 101   data  0x 4 0x 1 0xe1 0x 1
  program number  1030 has PID 0x 100   data  0x 4 0x 6 0xe1 0x 0
  program number  1152 has PID 0x 102   data  0x 4 0x80 0xe1 0x 2

2011-11-28 20:16:16.578 Using runtime prefix = /usr, libdir = /usr/lib
2011-11-28 20:16:16.587 Empty LocalHostName.
2011-11-28 20:16:16.588 Using localhost value of myth
2011-11-28 20:16:16.600 New DB connection, total: 1

A quick look in dmesg had the following:

[531455.906876] mythbackend[6451]: segfault at 0000004a eip b53c9a5c
esp aa2f5d3c error 4

And for the record:

djwhyte at myth:~$ mythbackend --version
Please include all output in bug reports.
MythTV Version   : 16838
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux profile using_oss using_alsa using_arts using_jack
using_backend using_dbox2 using_dvb using_firewire using_frontend
using_hdhomerun using_iptv using_ivtv using_joystick_menu
using_libfftw3 using_lirc using_opengl_vsync using_opengl_video
using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw
using_xvmc_vld using_glx_proc_addr_arb using_bindings_perl
using_bindings_python using_opengl using_ffmpeg_threads
using_libavc_5_3 using_live
djwhyte at myth:~$

I realise this is an old release but just in case it is of any use to
anyone, I thought I would post it to the list.

Anyone have any idea what caused the segfault and whether it has been
fixed in a more recent release?

Cheers,
Whytey


More information about the mythtv-users mailing list