[mythtv-users] Need help connecting MythTV to bluetooth headset

Craig Huff huffcslists at gmail.com
Sat Oct 1 20:12:01 UTC 2011


Hmmm.  Nothing works, even help found googling.

I am running MythBuntu 10.04, which leaves me with limited GUI tools
to work with bluetooth.  The tool found in the menu "Applications >
Settings > Bluetooth" can find and pair with my Motorola S9-HD
headset, but I can get no further.  Why?

If I unpair the headset and delete the device definition there (and
_only_ if I do delete it completely), I can then use hcitool to find
the device with "$hcitool scan".  Once I could scan and get the
headset's MAC address, I was then able to create a definition in
~/.asoundrc, and run "$hciconfig hci0 voice 0x0060" to set it up, but
"$aplay -L" still does not list the headset as a supported device (I'm
not even sure - Should it?), and "$aplay -D btheadset -f s16_le
/usr/share/sounds/alsa/Front_Center.wav" barfs with these messages:

        ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared
library /usr/lib/alsa-lib/libasound_module_pcm_bluetooth.so
        aplay: main:608: audio open error: No such file or directory

I then used Synaptics Package Manager to install the bluetooth
(4.60-0ubuntu8, FWIW) package, hoping it would address the missing
library issue.  It seems to have done so, but now the aplay command
barfs with:

        ALSA lib audio/pcm_bluetooth.c:1607:(audioservice_expect)
BT_GET_CAPABILITIES failed : Input/output error(5)
        aplay: main:608: audio open error: Input/output error

Now I'm stumped.  Where do I go from here?

Sigh... some days I just wish something would work the first time.

Any help would be appreciated.

Craig.


More information about the mythtv-users mailing list