[mythtv-users] unable to record to local ext4 partition

Tim Draper veehexx at gmail.com
Sun Oct 30 21:39:55 UTC 2011


On 30 October 2011 20:48, Nick Rout <nick.rout at gmail.com> wrote:

> On Mon, Oct 31, 2011 at 9:41 AM, Tim Draper <veehexx at gmail.com> wrote:
> > i've done some changes with how my mythtv is configured, which includes a
> > change in storage directory location onto another HDD.
> > however, every time i try to record, mythtv will start the recording but
> it
> > will not actually write to a file... i suspect it is a permissions issue.
> >
> > fstab of the Storage Group drive:
> >
> > /dev/sdb1       /data   ext4
> > noatime,data=writeback,barrier=0,nobh,errors=remount-ro     0       1
> >
> > 'Default' and 'livetv' SG's are pointing to (currently these are the only
> > two that have been set):
> >>
> >> /data/mythtv/Recordings
> >> /data/mythtv/LiveTV
> >
> > mythbackend log shows the following when i attempt to record:
> >
> > 2011-10-30 20:27:57.852 Reschedule requested for id 42.
> > 2011-10-30 20:27:58.039 Scheduled 44 items in 0.2 = 0.00 match + 0.18
> place
> > 2011-10-30 20:27:58.041 TVRec(1): ASK_RECORDING 1 0 0 0
> > 2011-10-30 20:27:58.055 TVRec(1): Changing from None to RecordingOnly
> > 2011-10-30 20:27:58.055 TVRec(1): HW Tuner: 1->1
> > 2011-10-30 20:27:58.078 AutoExpire: CalcParams(): Max required Free
> Space:
> > 3.0 GB w/freq: 14 min
> > 2011-10-30 20:27:58.079 Started recording: "The X Factor Results":
> channel
> > 13140 on cardid 1, sourceid 3
> > 2011-10-30 20:27:58.139 MainServer::ANN Monitor
> > 2011-10-30 20:27:58.139 adding: server as a client (events: 2)
> > 2011-10-30 20:27:58.143 MainServer::ANN Monitor
> > 2011-10-30 20:27:58.143 adding: server as a client (events: 2)
> > 2011-10-30 20:27:58.396 ProgramInfo(13140_20111030202800.mpg), Error:
> > GetPlaybackURL: '13140_20111030202800.mpg' should be local, but it can
> not
> > be found.
> > 2011-10-30 20:27:58.621 TVRec(2): ASK_RECORDING 2 0 0 0
> >
> > permissions of the folders at the new location. i have compared them to
> the
> > default ones at /var/lib/mythtv/, and they match based off 'ls -l'
> >
> >> /data/mythtv/$ ls -l
> >>
> >> total 48
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Banners
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Coverart
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 DB_Backups
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Default
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Fanart
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 20:27 LiveTV
> >> drwxrwsr-x 2 mythtv mythtv 12288 2011-10-30 20:27 Recordings
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Screenshots
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Trailers
> >> drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Videos
> >
> > I hope someone can help!
> > at the moment i'm guessing it's permissions, but cant work out what is
> going
> > wrong.
> >
>
> It is myth's built in X factor rejector.
>
> But really it os probably the permissions of some directory further up
> the path -
>
> ls -l /data
>

$ ls -l /data
total 32
drwxr-xr-x  4 veehexx veehexx  4096 2011-10-30 16:43 data
drwxrwxrwx  2 root    root    16384 2011-10-29 19:40 lost+found
drwxr-xr-x  4 veehexx veehexx  4096 2011-10-30 21:10 media
drwxrwxrwx 12 mythtv  mythtv   4096 2011-10-30 14:12 mythtv
drwxrwxrwx  2 root    root     4096 2011-10-30 14:41 restricted

^^ ignore that /data/data folder - moving stuff between HDD's

ls -l /data/mythtv
>
>
$ ls -l /data/mythtv
total 48
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Banners
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Coverart
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 DB_Backups
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Default
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Fanart
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 20:27 LiveTV
drwxrwsr-x 2 mythtv mythtv 12288 2011-10-30 20:27 Recordings
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Screenshots
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Trailers
drwxrwsr-x 2 mythtv mythtv  4096 2011-10-30 11:38 Videos

.... and just for good measure, /
$  ls -l /
total 84
drwxr-xr-x   2 root root  4096 2011-10-30 14:49 bin
drwxr-xr-x   3 root root  4096 2011-10-30 14:55 boot
drwxr-xr-x   2 root root  4096 2011-10-30 12:33 cdrom
drwxrwxrwx   7 root root  4096 2011-10-30 20:53 data


Did you verify that the filesystem was mounted rw instead of ro from
> your errors=remount-ro
>
>
it's mounted as RW - i'm currently FTPing data to /data.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20111030/e0fa0024/attachment.html 


More information about the mythtv-users mailing list