[mythtv-users] HDMI sound works for AC3 2-channel, but not 6-channel

Steven Ihde steve at x2.hamachi.us
Tue Apr 3 01:25:24 UTC 2012


On Apr 2, 2012, at 3:30 PM, Jean-Yves Avenard wrote:
> On Monday, 2 April 2012, Steven Ihde wrote:
> 
> Audio is set to Stereo, yes, although it is the only choice.  Dolby Digital and DTS are unchecked, as the HDMI cable is plugged directly into my TV, not a receiver/processor.
> 
> Please, do not top post..
> 
> That would make sense then... Audio has to be decoded and down mixed from 5.1 to stereo. This is done as a floating point operation.
> So your audio card is opened as stereo for an originally 6 channels audio (hence the 2(6) message in the log)
> 
> Now why it doesn't play is hard to understand, especially if you're saying that plain stereo works...
> 
> Are you able to compile mythtv yourself? I'd like to try something with you... 

Yes, I can build from source.  I'm happy to try any suggestions you have.  I was expecting to see a message about "downmixing" from 6 to 2 channels but I don't see one.

Sorry I missed your earlier message asking for more logs; pasted a longer log segment below.

2012-04-01 23:30:20.796 AFD: EIA-708 caption service #1 is in the English language.
2012-04-01 23:30:20.797 AFD: Using vdpau for video decoding
2012-04-01 23:30:20.797 AFD: Looking for decoder for MPEG2VIDEO
2012-04-01 23:30:20.797 AFD: Opened codec 0x3b65670, id(MPEG2VIDEO) type(Video)
2012-04-01 23:30:20.797 AFD: Stream #1, has id 0x33 codec id AC3, type Audio, bitrate 384000 at 0x3948bc0
2012-04-01 23:30:20.797 AFD: codec AC3 has 6 channels
2012-04-01 23:30:20.797 AFD: Looking for decoder for AC3
2012-04-01 23:30:20.798 AFD: Opened codec 0x3b65ad0, id(AC3) type(Audio)
2012-04-01 23:30:20.798 AFD: Stream #2, has id 0x34 codec id AC3, type Audio, bitrate 64000 at 0x3ba4670
2012-04-01 23:30:20.798 AFD: codec AC3 has 1 channels
2012-04-01 23:30:20.798 AFD: Looking for decoder for AC3
2012-04-01 23:30:20.798 AFD: Opened codec 0x3aa5ee0, id(AC3) type(Audio)
2012-04-01 23:30:20.798 AFD: Stream #3, has id 0x35 codec id AC3, type Audio, bitrate 64000 at 0x39700b0
2012-04-01 23:30:20.799 AFD: codec AC3 has 1 channels
2012-04-01 23:30:20.799 AFD: Looking for decoder for AC3
2012-04-01 23:30:20.799 AFD: Opened codec 0x3aa6340, id(AC3) type(Audio)
2012-04-01 23:30:20.978 AO: Opening audio device 'iec958:CARD=CMI8768,DEV=0' ch 2(6) sr 48000 sf signed 32 bit reenc 0
2012-04-01 23:30:20.981 ALSA, Error: Unable to sufficiently increase ALSA hardware buffer size - underruns are likely
2012-04-01 23:30:20.986 AudioPlayer: Enabling Audio
2012-04-01 23:30:20.987 Dec: Selected track #1 in the Unknown language(0)
2012-04-01 23:30:20.987 Dec: Selected track #1 in the English language(6647399)

The only subsequent mention of audio is the following:

2012-04-01 23:30:21.271 Player(0): Forcing decode extra audio option on (Video method requires it).

Note the "Unable to sufficiently increase..." message occurs after I had already followed the instructions to manually increase the prealloc.  Before setting it to 128, I got a more extensive message like this:

2012-04-01 21:59:33.795 ALSA, Error: Setting hardware audio buffer size to 128
2012-04-01 21:59:33.796 ALSA, Error: Error opening /proc/asound/card1/pcm2p/sub0/prealloc: Permission denied.
2012-04-01 21:59:33.796 ALSA, Error: Try to manually increase audio buffer with: echo 128 | sudo tee /proc/asound/card1/pcm2p/sub0/prealloc
2012-04-01 21:59:33.796 ALSA, Error: Unable to sufficiently increase ALSA hardware buffer size - underruns are likely

Setting the size to 128 seems to make the first three messages go away, but the one about "Unable to sufficiently increase ..." remains.

In neither case do I ever see the "WriteAudio: buffer underrun" messages (i.e., neither when sound works nor  when it is silent), so I do not believe buffer underruns are the problem, but I am open to suggestion there as well.

Thanks,

Steve

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120402/11fa641a/attachment.html>


More information about the mythtv-users mailing list