[mythtv-users] Old recordings show incorrect lengths during playback

Anthony Giggins seven at seven.dorksville.net
Sun Apr 29 09:48:41 UTC 2012



On 29/04/2012, at 12:56 AM, "Michael T. Dean" <mtdean at thirdcontact.com> wrote:

> On 04/28/2012 01:02 AM, Simon Koch wrote:
>> On Fri, Apr 27, 2012 at 6:42 PM, Jim Stichnoth wrote:
>> 
>>> On Apr 26, 2012, at 9:14 PM, Simon Koch wrote:
>>> 
>>>> Since upgrading to 0.25, when I watch some of my old recordings the
>>>> length is displayed wrong in the OSD.  For example, some 30 minute
>>>> recordings of the Twilight Zone show lengths from 43 minutes to as much as
>>>> 10 and a half hours.  As I watch, the time progresses normally to 30
>>>> minutes when the recording stops.  On the other hand, the length displays
>>>> correctly when I edit the recording.
>>>> 
>>>> I haven't been able to identify much of a common thread between the
>>>> anomalous recordings.  They all seem to be from the PVR-250 and PVR-500
>>>> era, I haven't found any recordings that I know to be from Firewire or
>>>> HDHomeRun with this problem yet.  Not all of my MPEG encoder recordings
>>>> show the problem, though.  What should I look for to troubleshoot this, or
>>>> what information should I try to gather so I can write a useful bug report?
>>>>  I feel like I don't have much solid information to work with right now.
>>> This sounds like http://code.mythtv.org/trac/ticket/10623 .
>>> 
>> That's exactly it.  That's what I get for not re-checking the bug list
>> after I try investigating it on my own.
>> 
> 
> FWIW, the ticket is wrong about, "Running a mythcommflag --rebuild on the offending file will resolve the improper length, however it would take significant work to manually rebuild all existing recordings in the library impacted by this problem."
> 
> I have run --rebuild against all of nearly 2000 recordings and it took only a few seconds of my time (and a day or 2 of background computer time).  Just set up a script to loop over all the files in the recordings directories and queue a rebuild for each (and, for bonus points, have it skip any "new since upgrade" recordings).
> 
> Mike
> _______________________________________________
> 

Doesn't running
mythcommflag --rebuild

With no other parameters just run for all recordings?

Cheers,

Anthony


More information about the mythtv-users mailing list