[mythtv-users] mythtvsetup can't see dvb cards after kernel update

John Pilkington J.Pilk at tesco.net
Sun Jul 8 11:32:22 UTC 2012


On 08/07/12 10:47, John Pilkington wrote:
> On 06/07/12 11:56, Nick Rout wrote:
>> On Fri, Jul 6, 2012 at 10:49 PM, John Pilkington <J.Pilk at tesco.net>
>> wrote:
>>> On 06/07/12 08:34, Raymond Wagner wrote:
>>>>
>>>> On 7/1/2012 05:09, John Pilkington wrote:
>>>>>
>>>>> Deleting all cards and rescanning is rather a pain, so I haven't tried
>>>>> it.
>>>>
>>>>
>>>> Rescanning?  Channels are stored against the video source, which is
>>>> completely independent from the tuner cards.  It takes all of a minute
>>>> or two to delete your tuner cards, add them back, and attach the inputs
>>>> back up to the video source.
>>>
>>>
>>> Yes, when it works.  I just rebooted to f16 3.4.2-1 / nVidia 295.59 /
>>> myth
>>> 0.24.3 and did delete all, yes all, cards.  It still doesn't see any dvb
>>> hardware.  Two cards have analog sections which do appear.  I tried
>>> mythtvsetup -v all but didn't see anything that looked more
>>> informative than
>>> I've reported before.
>>>
>>> Scott Harris sent a 'me too' to the ATrpms list.  Fortunately I can
>>> revert
>>> to 3.3.7-1 / nVidia 295.49 and it Just Works.  I rescanned as well. That
>>> _is_ painfree once the correct set of transports is in the DB.
>>>
>>> I suppose the problem ought to go to Fedora or linux-media but
>>> testing puts
>>> the box effectively out of use.
>>
>>
>> Just cross posting this thread:
>>
>> http://www.gossamer-threads.com/lists/mythtv/mythtvnz/522430#522430
>
> That thread picked up on Lawrence's patch and reported success after
> changing the dtv_multiplex mod_sys setting to DVB-S;  in my table it's
> UNDEFINED, but the doxygen reference says that only DVB-S and DVB-S2 are
> supported atm.  I'm using dvb-t hardware, so neither seems relevant.
> Anyway, I wouldn't expect presence or absence of that field to affect
> myth's /detection/ of the hardware, which is what I'm using as the
> indicator of the problem.  This is v0.24.3-2-ge12af86.
> _______________________________________________

I've put a reference to this here:  it looks as if that is what has changed.

Don't customize V4L/DVB tuners or frontends

https://bugzilla.redhat.com/show_bug.cgi?id=825203#c9





More information about the mythtv-users mailing list