[mythtv-users] [SOLVED] Mythbuntu 12.04 /etc/mythtv/config.xml is empty & Access denied for user 'mythtv'@'localhost'

Kingsley Turner krt at krt.com.au
Mon Jul 9 03:05:19 UTC 2012


Hi - for the archive.

Symptom: Mythweb movie artwork does not show.
Symptom: In /var/log/apache/error.log there are a bunch of errors like:

[Mon Jul 09 11:51:57 2012] [error] [client 192.168.1.44] Cannot connect to 
database: , referer: http://192.168.1.20/mythweb/video
[Mon Jul 09 11:51:57 2012] [error] [client 192.168.1.44] , referer: 
http://192.168.1.20/mythweb/video
[Mon Jul 09 11:51:57 2012] [error] [client 192.168.1.44] Compilation failed 
in require at /var/www/mythweb/mythweb.pl line 61., referer: 
http://192.168.1.20/mythweb/video
[Mon Jul 09 11:51:57 2012] [error] [client 192.168.1.44] Premature end of 
script headers: mythweb.pl, referer: http://192.168.1.20/mythweb/video
[Mon Jul 09 11:51:57 2012] [error] [client 192.168.1.44] DBI 
connect('database=mythconverg:host=localhost;port=3306','mythtv',...) 
failed: Access denied for user 'mythtv'@'localhost' (using password: YES) at 
/usr/share/perl5/MythTV.pm line 351, referer: http://192.168.1.20/mythweb/video

(obviously the 192.168.1.20 is the address of my mythtv box, yours might be 
different)

I'm not sure what the root cause of the problem is, but I think mythweb is 
using /etc/mythtv/config.xml by default.  On my fresh installation of 
Mythbuntu 12.04 this is an empty file.  I removed the 0 byte file, and 
symlinked to the real config.xml in my configured user directory

e.g.:
         cd /etc/mythtv
         sudo rm config.xml
         sudo ln -sf /home/<your-user-name>/.mythtv/config.xml config.xml


Having this empty config.xml causes mythweb not to be able to connect to the 
database for the artwork.  It does seem to be able to connect for other 
things, so I'm not 100% sure what the matter is.


hope this helps someone,

cheers,
-kt





More information about the mythtv-users mailing list