[mythtv-users] 0.25 and V4L not working

Michael T. Dean mtdean at thirdcontact.com
Thu Mar 22 06:23:29 UTC 2012


On 03/22/2012 02:19 AM, Michael T. Dean wrote:
> On 03/22/2012 12:31 AM, Eric B wrote:
>>> What distro? Where did you get MythTV (from a package or
>>> built-from-source)?
>> I am running ubuntu 10.04, kernel 2.6.32-39 generic and was using the
>> packages for the mythbuntu repo
>>
>>> What MythTV version (output of mythbackend --version)?
>> sorry I forgot to do this before I uninstalled to build from source,  it
>> was 0.25.beta....something...
>>
>>> What did you use for configure options? What is the output of:
>>> find /usr/include -name '*videodev*'
>> /usr/include/linux/videodev.h
>> /usr/include/linux/videodev2.h
> Hmmm, that means the patch is unlikely to do anything--though it also
> means that your V4L-based device should work fine.  What capture
> device?  Is it an ivtv-based device?
>
>> I've applied your patch and am going to try and build of source tonight...
>> hopefully I will be able to give you results after works tomorrow.
>>
>> I used
>> git clone git://github.com/MythTV/mythtv.git
>> git clone git://github.com/MythTV/mythweb.git*
>> to get the myth code
>> *
>> used
>> ./configure --enable-vdpau --enable-libx264 --enable-libfaac
>> --enable-libmp3lame --enable-nonfree
> Not a bad configure line, but might want to also use --enable-proc-opt

Actually, try taking out the --enable-nonfree, too--that doesn't seem to 
be a MythTV configure option, so you may be building things wrong with 
it in there.

Mike


More information about the mythtv-users mailing list