[mythtv-users] Mythtv UI and Playback much too dark, colors out of balance

Michael T. Dean mtdean at thirdcontact.com
Fri Sep 7 05:19:10 UTC 2012


On 09/06/2012 11:07 PM, Jeremy Crandell wrote:
> From: Michael T. Dean
>> On 09/04/2012 12:01 PM, Jeremy Crandell wrote:
>>> Last week I did an apt-get upgrade on my mythbuntu system and ever since then my my blacks have been messed up.  The picture is too dark to see what is going on with most videos, unless the video is of an outdoor scene .  The colors aren't balanced either; sometime too red, sometime too green.  I have tried adjusting the contrast, brightness, and gamma both with the nvidia-settings tool and on the TV.  These adjustments have an effect and make it passable, but the adjustments taht I make for one video are too much or too little for the next.  I find that I have to adjust the settings for whatever video I'm watching just so I can se what is going on.  I played back some video with VLC and the color was fine.
>>>
>>> The issue was bugging me so much that I backed up and reinstalled yesterday hoping that would fix the problem.  It didn't.
>>>
>>> My system has an Athalon II processeor, Muthbuntu 12.04 64-bit, GeForce 210 video card, conncted to LCD HD TV via HDMI.  I am using the post-release nvidia driver from the ubuntu repositories.  I have VDPAU set to Normal.
>> Sounds like you need to properly configure studio colors on your system (meaning having both MythTV and your nvidia drivers properly configured to work together).  Check the archives for more:  http://www.gossamer-threads.com/lists/mythtv/
> Thank you for the response, Mike.  I searched the archive for "studio colors" and read through the threads.  I do agree that it seems that the values being passed to the TV for black are out of range.  I have used the nVidia-Settings tool to change the color space between YCbCr444, RGB-Full, and RGB-Limited.  I could not see a change in video playback for any of these settings.  And, as I mentioned in the first post, the color looks fine if I play the content back in VLC.  I know its not the recording source because I can transfer the recording to a different PC and the playback colors are fine.  You had mentioned that I needed to get the settings of MythTV and the Drivers properly configured to work together.  I know where to make the changes in the Driver.  Where do I make the changes in MythTV.  I can't seem to find anything in the wiki explaining the settings.  I'm probably just not searching with the right terms.  Any help would be
>   appreciated.
>

In MythTV, enable or disable studio colors using the MENU during playback.

Mike



More information about the mythtv-users mailing list