[mythtv-users] Mythtv for Android Problem

Bill Meek keemllib at gmail.com
Sun Sep 23 15:46:21 UTC 2012


On 09/23/2012 09:32 AM, Ken Mandelberg wrote:
> I just tried Mythtv for Android Update 2012-09-22, the first version I've tried.
>
> It does list my recordings, but when I select one I get  the "please wait retrieving video" with the rotating circle forever.
>
> I'm running against the trunk backend, which I set manually. The Android side is a Nexus 7 running JB.
>
> I haven't selected a player, presuming it would prompt for one if it got past the "please wait".
>
> What can I do to debug this? I don't see anything in the backend log.

Hi;

Some ideas:

Use:

  mythbackend --setverbose upnp (and mythbackend --setloglevel debug)

You should see lines that include something like:

  ExtractMethodFromURL(end) : AddLiveStream : /Content
  ServiceHost::ProcessRequest: AddLiveStream : GET /Content/AddLiveStream?FileName=1021_20120806020000.mpg&HostName=mc1&Height=360&
     Bitrate=500000& AudioBitrate=96000&SampleRate=48000 HTTP/1.1
  AddLiveStream - StorageGroup missing... using 'Default'
...
  ExtractMethodFromURL(end) : 1021_20120806020000.mpg.640x368_500kV_96kA.av.m3u8 : /StorageGroup/Streaming
  HTTPRequest::SendResponse( File ) :200 OK -> 192.168.10.139:
  SendResponseFile ( /var/lib/mythtv/storage/streaming/1021_20120806020000.mpg.640x368_500kV_96kA.av.m3u8 )
  ...

If you're using the --logpath option, look in mythtranscode.<time>.<pid>.log.

Don't forget: --enable-libx264 and --enable-libmp3lame from:
    http://www.mythtv.org/wiki/Http_live_streaming_server.

Bill


More information about the mythtv-users mailing list