<div class="gmail_quote">On Mon, Dec 6, 2010 at 10:32 AM, P.J. Trudell <span dir="ltr">&lt;<a href="mailto:pjtrudell@yahoo.com">pjtrudell@yahoo.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<table cellspacing="0" cellpadding="0" border="0"><tbody><tr><td valign="top" style="font:inherit">Hello everyone,<br>I just got a new HD-PVR and I seem to be having some trouble.  I am running Ubuntu 10.04 and I updated to the new firmware as per <a href="http://www.mythtv.org/wiki/Hauppauge_HD-PVR" target="_blank">http://www.mythtv.org/wiki/Hauppauge_HD-PVR</a>.<br>
<br>Since my kernel is  &quot;Linux myth-server 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:24:00 UTC 2010 i686 GNU/Linux&quot; I did not compile anything because the drivers should be included.<br><br>I did a modprobe and had no errors<br>
<br>My problem is I have no extra /dev/videoX<br><br><br>
I have a Houppauge HVR2250 and a Hauppauge 500 so I have a dev/video0, 
video1, video 22, video23, video 32, video33, and dev/dvb/adapter0, 
adapter1<br><br>but nothing new that I can telll after adding the HDPVR.<br>
<br>
Mythtv-setup does not probe anything for HD-PVR card.<br><br>If it matters I have it hooked up to a Directv H23-600 that was connected to my other tv directly with an hdmi cable.<br>Directv.pl seems to be working (from the command line) using the H20 device.<br>
<br>Below is some info that I hope will help.  <br>Thanks<br>P.J.<br><br>dmesg |grep hdpvr returns <br>[  506.260626] usbcore: registered new interface driver hdpvr<br><br><br>modinfo hdpvr returns<br>filename:       /lib/modules/2.6.35-22-generic/kernel/drivers/media/video/hdpvr/hdpvr.ko<br>
description:    Hauppauge HD PVR driver<br>author:         Janne Grunau<br>license:        GPL<br>srcversion:     F9BCAADA7960A2E15A08EBA<br>alias:         
 usb:v2040p4982d*dc*dsc*dp*ic*isc*ip*<br>alias:          usb:v2040p4902d*dc*dsc*dp*ic*isc*ip*<br>alias:          usb:v2040p4901d*dc*dsc*dp*ic*isc*ip*<br>alias:          usb:v2040p4900d*dc*dsc*dp*ic*isc*ip*<br>depends:        videodev,v4l2-common<br>
vermagic:       2.6.35-22-generic SMP mod_unload modversions 686 <br>parm:           video_nr:video device number (-1=Auto) (array of int)<br>parm:           hdpvr_debug:enable debugging output (int)<br>parm:           default_video_input:default video input: 0=Component / 1=S-Video / 2=Composite
 (uint)<br>parm:           default_audio_input:default audio input: 0=RCA back / 1=RCA front / 2=S/PDIF (uint)<br>parm:           boost_audio:boost the audio signal (bool)<br><br>lsusb |grep Hauppauge returns<br>Bus 001 Device 004: ID 2040:4903 Hauppauge <br>
<br></td></tr></tbody></table></blockquote><div><br></div><div>Looks like you have a model newer than the kernel module has support for (4900-&gt;4902,4982) - In fact, it is still not in 2.6.36.  You may ping the v4l mailing list to see if someone has added it.  It is probably as simple as adding it to the code; though I am not sure..  It may already be there in someone&#39;s git repo..</div>
<div><br></div><div><div>/* Define these values to match your devices */</div><div>#define HD_PVR_VENDOR_ID        0x2040</div><div>#define HD_PVR_PRODUCT_ID       0x4900</div><div>#define HD_PVR_PRODUCT_ID1      0x4901</div>
<div>#define HD_PVR_PRODUCT_ID2      0x4902</div><div>#define HD_PVR_PRODUCT_ID3      0x4982</div></div><div><meta http-equiv="content-type" content="text/html; charset=utf-8">#define HD_PVR_PRODUCT_ID4      0x4903</div></div>