<font color='black' size='2' face='arial'><font color="black" face="arial" size="2">

<div> <font face="Arial, Helvetica, sans-serif">I checked this with ffmpeg</font><font><font color="black" face="arial" size="2"><font face="Arial, Helvetica, sans-serif"> </font></font></font><font face="Arial, Helvetica, sans-serif"> and apparently work have been done regarding this. The </font><font><font color="black" face="arial" size="2"><font face="Arial, Helvetica, sans-serif">ffmpeg</font></font></font><font face="Arial, Helvetica, sans-serif"> </font>trunk version appears to be demuxing the subtitles stream correctly (although the latest ffmpeg release version still does not, IMHO).<br>
<br>
When could I expect to see the new version integrated with Myth? (version 0.25 only?). I wouldn't mind giving the integration a try myself, but I think there is a lot of knowhow related to this I will need to catch up on. Where should I start?<br>

</div>



<div> <br>

</div>



<div style="clear: both;"></div>



<div> <br>

</div>



<div> <br>

</div>



<div style="font-family: arial,helvetica; font-size: 10pt; color: black;">-----Original Message-----<br>

From: Mark Kendall &lt;mark.kendall@gmail.com&gt;<br>

To: yoav@mindless.com<br>

Sent: Wed, Dec 8, 2010 4:05 am<br>

Subject: Re: [mythtv-users] Problem: DVB subtitles not showing<br>

<br>








<div id="AOLMsgPart_0_dfe84a24-9f48-40a7-a534-8414f358147c" style="margin: 0px; font-family: Tahoma,Verdana,Arial,Sans-Serif; font-size: 12px; color: rgb(0, 0, 0); background-color: rgb(255, 255, 255);">

<pre style="font-size: 9pt;"><tt>On 6 December 2010 19:18,  &lt;<a href="mailto:yoav@mindless.com">yoav@mindless.com</a>&gt; wrote:<br>

&gt; I placed a 10MByte clip (violently chopped from the original using dd) under<br>

&gt; <a href="http://filebin.ca/yhfott/2004_20101205131605.mpg" target="_blank">http://filebin.ca/yhfott/2004_20101205131605.mpg</a><br>

&gt; I verified (using VLC) that the subtitles are there.<br>

<br>

If you play back your clip with mythfrontend -v playback, you'll<br>

notice this in the log:-<br>

<br>

2010-12-08 10:01:58.251 AFD: Stream #4, has id 0x40e codec id<br>

DVB_SUBTITLE, type Subtitle, bitrate 0 at 0xa9237f90<br>

2010-12-08 10:01:58.251 AFD: subtitle codec (Subtitle)<br>

2010-12-08 10:01:58.251 AFD: Looking for decoder for DVB_SUBTITLE<br>

2010-12-08 10:01:58.251 [dvbsub @ 0x4d92ea0]Invalid extradata,<br>

subtitle streams may be combined! &lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;&lt;<br>

2010-12-08 10:01:58.251 AFD: Opened codec 0xa9238160, id(DVB_SUBTITLE)<br>

type(Subtitle)<br>

2010-12-08 10:01:58.251 AFD: Subtitle track #3 is A/V stream #4 and is<br>

in the Hebrew language(6841698).<br>

<br>

ffmpeg clearly doesn't like those dvb subtitle streams for some reason<br>

and mplayer also fails to play them. VLC uses a different demuxer and<br>

is obviously happier.<br>

<br>

I suggest you raise a ticket with ffmpeg.<br>

<br>

Regards<br>

<br>

Mark<br>

</tt></pre>
</div>

 <!-- end of AOLMsgPart_0_dfe84a24-9f48-40a7-a534-8414f358147c -->

</div>

</font></font>