Difference between revisions of "Talk:MCE Remote"

From MythTV Official Wiki
Jump to: navigation, search
 
(Dell branded MCE remote and transmitter)
 
(14 intermediate revisions by 7 users not shown)
Line 1: Line 1:
Doesn't this page discuss the setup of the IR receiver, not the remote itself?  Maybe the page should be segmented, as it is unclear. It should be noted that the remote will work with other IR receivers. It should be noted that this remote uses toggle codes.  Also, should mention that the TV, Vol+, Vol- buttons are learning.
+
== Hauppauge WinTV-PVR-USB2 MCE Remote ==
 +
 
 +
[http://g-ding.tv/ MythDora] supports it!
 +
 
 +
== Newest Hauppauge v1069 remote and USB IR receiver ==
 +
 
 +
I have the latest remote ordered from the Hauppauge website just 3 weeks ago.
 +
It doesn't work with the lirc_mceusb2 module... it requires the lirc_mceusb module.
 +
 
 +
Everything I'd read pointed me to the mceusb2 module to get the thing working... after two weeks of ripping my hair out -- I finally compiled the mceusb module and the remote works...
 +
 
 +
Any suggestions on how I should update the page to indicate that the latest (black colored) Hauppauge remotes require the old mceusb driver, not the new one?
 +
 
 +
UPDATE: I think my above assumptions may be wrong -- but I haven't been able to communicate with any other actual person regarding their success in getting the new black remote working.
 +
 
 +
I have it working now -- but whether that was due to adding lirc_mceusb support or rather just recompiling and reinstalling the mceusb2 module has yet to be tested.
 +
 
 +
 
 +
== Microsoft MCEusb ver 2 ==
 +
I have the 1039 remote with the 1040 receiver. Every line on this article is confirmed. Saved me hours of wondering why could change a channel on my TV set.
 +
 
 +
Thanks for the information.
 +
 
 +
--[[User:Eaggel|Eaggel]] 00:14, 4 January 2009 (UTC)
 +
 
 +
== Need troubleshooting section for transmitter ==
 +
 
 +
It seems to be a common problem that the receiver for this remote works fine (out of the box on Mythbuntu) but the transmitter just does not send anything.  No error codes are seen; irsend LIST "" "" looks like everything is set up right for the transmitter, and there is no visible blinking on the USB boxI have this problem and have come across several similar reports, with no follow-up.  If anybody has any idea please add a troubleshooting section for it.
 +
 
 +
--[[User:Mjrice|Mjrice]] 17:07, 23 August 2009 (UTC)
 +
 
 +
In response to Mjrice:
 +
You can always check if an IR Blaster is working by viewing the IR LED through a CCD camera such as that on your mobile phone. The IR light will be visible.
 +
 
 +
--[[User:Xebozone|Xebozone]] 06:06, 26 November 2009 (UTC)
 +
 
 +
== Pinnacle Remote ==
 +
 
 +
Pinnacle has a "black" remote without the coloured buttons at the bottom in their MCE kit.
 +
Has anyone tried out the kit?
 +
 
 +
Pic: http://images.tigerdirect.com/skuimages/large/Pinnacle-PCTV-MCE-Comp-3.jpg
 +
 
 +
Secondly, is the Hauppauge MCE kit with the black remote compatible? Is this the same as on the page?
 +
Pic: http://shop.zenpc.co.za/images/hauppauge_remote_kit.jpg
 +
 
 +
--[[User:Xebozone|Xebozone]] 06:06, 26 November 2009 (UTC)
 +
 
 +
== Dell branded MCE remote and transmitter ==
 +
 
 +
The dell branded receiver looks the same as the Philips model listed on the wiki. Using lirc-0.8.6, only the second transmitter port works (IR2). However, after adding the philips line to lirc-0.8.6/drivers/lirc_mceusb/lirc_mceusb.c causes the first transmitter (IR1) to work as well.
 +
 
 +
static struct usb_device_id transmitter_mask_list[] = {
 +
    { USB_DEVICE(VENDOR_SMK, 0x031d) },
 +
    { USB_DEVICE(VENDOR_SMK, 0x0322) },
 +
    { USB_DEVICE(VENDOR_SMK, 0x0334) },
 +
    { USB_DEVICE(VENDOR_TOPSEED, 0x0001) },
 +
    { USB_DEVICE(VENDOR_TOPSEED, 0x0006) },
 +
    { USB_DEVICE(VENDOR_TOPSEED, 0x0007) },
 +
    { USB_DEVICE(VENDOR_TOPSEED, 0x0008) },
 +
    { USB_DEVICE(VENDOR_TOPSEED, 0x000a) },
 +
    { USB_DEVICE(VENDOR_PINNACLE, 0x0225) },
 +
  { USB_DEVICE(VENDOR_PHILIPS, 0x060c) },
 +
    {}
 +
};
 +
 
 +
The receiver works great.
 +
 
 +
-Rajil

Latest revision as of 19:08, 10 December 2009

Hauppauge WinTV-PVR-USB2 MCE Remote

MythDora supports it!

Newest Hauppauge v1069 remote and USB IR receiver

I have the latest remote ordered from the Hauppauge website just 3 weeks ago. It doesn't work with the lirc_mceusb2 module... it requires the lirc_mceusb module.

Everything I'd read pointed me to the mceusb2 module to get the thing working... after two weeks of ripping my hair out -- I finally compiled the mceusb module and the remote works...

Any suggestions on how I should update the page to indicate that the latest (black colored) Hauppauge remotes require the old mceusb driver, not the new one?

UPDATE: I think my above assumptions may be wrong -- but I haven't been able to communicate with any other actual person regarding their success in getting the new black remote working.

I have it working now -- but whether that was due to adding lirc_mceusb support or rather just recompiling and reinstalling the mceusb2 module has yet to be tested.


Microsoft MCEusb ver 2

I have the 1039 remote with the 1040 receiver. Every line on this article is confirmed. Saved me hours of wondering why could change a channel on my TV set.

Thanks for the information.

--Eaggel 00:14, 4 January 2009 (UTC)

Need troubleshooting section for transmitter

It seems to be a common problem that the receiver for this remote works fine (out of the box on Mythbuntu) but the transmitter just does not send anything. No error codes are seen; irsend LIST "" "" looks like everything is set up right for the transmitter, and there is no visible blinking on the USB box. I have this problem and have come across several similar reports, with no follow-up. If anybody has any idea please add a troubleshooting section for it.

--Mjrice 17:07, 23 August 2009 (UTC)

In response to Mjrice: You can always check if an IR Blaster is working by viewing the IR LED through a CCD camera such as that on your mobile phone. The IR light will be visible.

--Xebozone 06:06, 26 November 2009 (UTC)

Pinnacle Remote

Pinnacle has a "black" remote without the coloured buttons at the bottom in their MCE kit. Has anyone tried out the kit?

Pic: http://images.tigerdirect.com/skuimages/large/Pinnacle-PCTV-MCE-Comp-3.jpg

Secondly, is the Hauppauge MCE kit with the black remote compatible? Is this the same as on the page? Pic: http://shop.zenpc.co.za/images/hauppauge_remote_kit.jpg

--Xebozone 06:06, 26 November 2009 (UTC)

Dell branded MCE remote and transmitter

The dell branded receiver looks the same as the Philips model listed on the wiki. Using lirc-0.8.6, only the second transmitter port works (IR2). However, after adding the philips line to lirc-0.8.6/drivers/lirc_mceusb/lirc_mceusb.c causes the first transmitter (IR1) to work as well.

static struct usb_device_id transmitter_mask_list[] = {

   { USB_DEVICE(VENDOR_SMK, 0x031d) },
   { USB_DEVICE(VENDOR_SMK, 0x0322) },
   { USB_DEVICE(VENDOR_SMK, 0x0334) },
   { USB_DEVICE(VENDOR_TOPSEED, 0x0001) },
   { USB_DEVICE(VENDOR_TOPSEED, 0x0006) },
   { USB_DEVICE(VENDOR_TOPSEED, 0x0007) },
   { USB_DEVICE(VENDOR_TOPSEED, 0x0008) },
   { USB_DEVICE(VENDOR_TOPSEED, 0x000a) },
   { USB_DEVICE(VENDOR_PINNACLE, 0x0225) },
  { USB_DEVICE(VENDOR_PHILIPS, 0x060c) },
   {}

};

The receiver works great.

-Rajil