User:Marco.hahn

From MythTV Official Wiki
Revision as of 17:24, 12 September 2010 by Wagnerrp (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

My aim was to replace the four boxes and remote controls in our living room (CRT TV, DVB-T set-top box, VHS video recorder, DVD player) with just two (CRT TV, mythTV HTPC).

I plan to add some of the procedures I had to go through to get the system up and running.

If anyone needs some more details, feel free to send me an email.

Hardware

  • Asus M2NPV-VM
    • offers onboard graphics and gigabit network (driver currently only supports 100 MBit)
    • could not get onboard sound (AD1986A) to work flawlessly, got another sound card
    • full-height bracket for TV out included
  • Athlon XP 3500+ (PIB package with rather noisy fan, may need replacement)
  • 512 MB DDR2 PC667
  • Dual Hauppauge WinTV Nova-T USB2
    • work together without troubles
    • external devices, quite a bit of cabling out of the box
    • remote control supported by kernel 2.6.17 as keyboard device
  • Hercules Gamesurround Muse LT (half height but only with full height bracket)
  • Western Digital 1200BEVS Scorpio (120 GB)
    • 2.5 inch laptop hard disk
    • very quiet
  • Aopen H360A Black Slimline case
    • three half-height slots available, severely limits the choice of PCI boards for additional hardware (e.g. sound board)
    • reasonable price
    • with power supply and quiet fan
    • offers no good installation point for 2.5 inch hard disk

Software

  • Gentoo 2006.1 (networkless, creates a lot of problems when installing or upgrading software)
  • MythTV 0.19 (rev. 10505)
  • firmware dvb-usb-nova-t-usb2-02.fw (google for it)

Open issues

Feedback is very welcome!

  • MythTV always start in MythTV, not in MythWelcome. This means that it never shuts down after a timed recording.
  • Color is rather bleak (SVideo over SCART to no-name TV, could be a TV problem)
  • Sound mute on first TV or media playback, always OK on second try
  • Videotext

Details

Onboard sound troubles

  • this cost me most of the time setting up the system
    • lecture learned: check for Linux fully supported hardware, or just change it!
  • first no sound at all
  • then high-pitched noise all the time (also with other applications)
  • fragile: sound disappears after changing the volume
  • upgrade to MythTV 0.20 did not fix these issues
  • ALSA 1.0.11 (as mentioned in the web) did not fix these issues

Using the Hauppauge remote control

The remote control is supported by newer 2.6 kernels (AFAIR 2.6.10 upwards, Gentoo 2006.1 uses 2.6.17). However, only a few keys (left, right, up, down, 0 .. 9) map to normal keys, the rest are setup as multimedia keys which do not work out of the box with MythTV. My solution was to patch the driver source file drivers/media/dvb/dvb-usb/nova-t-usb2.c with standard keys of my liking (take #defines from include/linux/input.h). Some finetuning with MythControls may be necessary. This is definitely less trouble than installing lineak, or something like that.

Reordering the channels in the EPG

Without any extra software: With mysqld running, enter

mysql --user mythtv --password -D mythconverg

and enter the password. Then, for each channel do

update channel set channum=<new> where channum=<old>;

with <new> being the channel number you want MythTV to use in future and <old> being the channel number it is currently using. Make sure not to assign <new> to any number already in use. It may be necessary to adjust the order of the commands a little bit.

Alternatively, it is possible to use ... where chanid=<old>; or any other column name of the table as long as it is unique.

System startup

  • used runlevel 4 as described in url://www.linux.com/howtos/Kiosk-HOWTO.shtml#toc4
  • added own script with rc-update add to start mysqld (pause five seconds), mythbackend (pause two seconds), and mythwelcome

Encountered strange problems

  • Muse LT hides NOVA-T-USB2 if they are on USB hub 1, moving NOVA-T-USB2 to other hub (there are 2x2 USB sockets on the back of the mainboard) solved the problem

Resume

The system works in daily use. Even though it has some quirks, my whole family uses it and not the old DVB-T receiver that's still installed for backup uses. DVD player and VCR have beem removed.