Talk:Lirc on Ubuntu Dapper

From MythTV Official Wiki
Jump to: navigation, search

q: What on earth is the point of this article? Why not switch to Slackware or LFS if package management is unwanted?

a: Package-based installation is wanted. I read the README on the binary package, and it recommended compiling the modules from source. If anyone would like to test the instructions below & merge them into the main page, I'd appreciate it. --FuzzyWuzzy

"lirc-modules-source" is the Ubuntu package containing LIRC 0.80. install it, run "dpkg-reconfigure -plow lirc-modules-source" to configure it. Check the readme it comes with. It covers almost all of this article all by itself.

a: Updated: I tested the above procedure on 2/20/07 and found it was more of a hassle to use the lirc-modules-source package to compile the module portion of LIRC than just compiling it with the procedure I wrote in the article. --Fuzzywuzzy

Snapstream Firefly Remote

I am getting close to getting this guide to work with Snapstream Firefly Remote

Differences:

  • When configuring select "1. 8. USB devices 1. ATI/NVidia/X10 I & II RF Remote"
  • The driver is lirc_atiusb.ko
  • Replace all references of 'lirc_i2c' with 'lirc_atiusb'
  • You will need the remote config from Snapstream_Firefly

And by almost I mean it isn't working when I run dmesg I get:

[17179594.940000] lirc_dev: IR Remote Control driver registered, at major 61 
[17179595.020000] lirc_atiusb: no version for "lirc_unregister_plugin" found: kernel tainted.
[17179595.024000] 
[17179595.024000] lirc_atiusb: USB remote driver for LIRC v0.5
[17179595.024000] lirc_atiusb: Paul Miller <pmiller9@users.sourceforge.net>
[17179595.028000] lirc_dev: lirc_register_plugin: sample_rate: 0
[17179595.048000] lirc_atiusb[3]: X10 Wireless Technology Inc USB Receiver on usb1:3
[17179595.048000] ts: Compaq touchscreen protocol output
[17179595.060000] usbcore: registered new driver lirc_atiusb
[17179599.340000] cx25840 0-0044: loaded v4l-cx25840.fw firmware (16382 bytes)

But when I run mode2 I get

mode2: /dev/lirc is not a character device
mode2: use the -d option to specify the correct device

Which is odd because when I first installed lirc is worked and recognized my keypresses, but after reboot nothing works.

Response to Snapstream Firefly Remote

Please double-check section 3.4 --FuzzyWuzzy

Fix for erroring lircd/irw

The directions for setting up lirc worked without incident until where it said to reboot and then run irw. When running irw after startup it produced this error message:

connect: Connection refused.

When you run mode2 it said

mode2: /dev/lirc is not a character device 
mode2: use the -d option to specify the correct device

even though it worked before rebooting. Lastly, running 'lircd' returned to a prompt without anything at all to say. After looking for a long time on google and doing much research, I found that by adding '-d /dev/lirc/0' to lircd to make

lircd -d /dev/lirc/0

would correctly start lircd, allowing you to run irw and use your remote in MythTV. Hope this helps.

Rebuttal for erroring lircd/irw

I ran across the same problem initially. One of the files in section 3.4 (I forget which one) takes care of the problem. -- FuzzyWuzzy

Rebuttal Rebuttal

I get this error, and I have checked section 3.4, and rechecked, and rechecked... All was going correctly until the reboot, then it fails. -- BadlandZ