Difference between revisions of "Buildslave Fedora"

From MythTV Official Wiki
Jump to: navigation, search
(Created page with "= Creating a Fedora Buildslave = This is what you need to install to create a build slave running Fedora 18,19 or 20 == Build Dependencies == === MythTV Core === yum inst...")
 
m (Add in libtool requirement)
 
(6 intermediate revisions by one other user not shown)
Line 1: Line 1:
 
= Creating a Fedora Buildslave =
 
= Creating a Fedora Buildslave =
 +
[[User:Stuarta|stuarta]] 13:51, 3 March 2014 (UTC)
  
 
This is what you need to install to create a build slave running Fedora 18,19 or 20
 
This is what you need to install to create a build slave running Fedora 18,19 or 20
  
 
== Build Dependencies ==
 
== Build Dependencies ==
 +
 +
Some essential basics
 +
 +
yum install gcc gcc-c++ ccache git gdb
 +
 +
=== Qt Library ===
 +
 +
Choose '''EITHER''' Qt4 or Qt5.
 +
* Qt4 is the current supported release across all versions of MythTV and all distros.
 +
* Qt5 is bleeding edge alpha quality at this time. Support is expected from 0.28 onward. 0.27 might compile, but has runtime issues
 +
 +
==== Qt4 ====
 +
 +
yum install qt-devel qtwebkit-devel
 +
 +
==== Qt5 ====
 +
 +
yum install qt5-qtbase-devel qt5-qtwebkit-devel qt5-qtscript-devel \
 +
    libXinerama-devel libXrandr-devel libXv-devel
 +
 +
yum install freetype-devel
  
 
=== MythTV  Core ===
 
=== MythTV  Core ===
yum install gcc gcc-c++ qt-devel ccache git qtwebkit-devel gdb
 
 
 
  yum install yasm libxml2-devel MySQL-python python-lxml \
 
  yum install yasm libxml2-devel MySQL-python python-lxml \
 
     perl\(ExtUtils::MakeMaker\) perl\(DBI\) perl\(DBD::mysql\) \
 
     perl\(ExtUtils::MakeMaker\) perl\(DBI\) perl\(DBD::mysql\) \
Line 27: Line 47:
 
* for zeromq
 
* for zeromq
  
  yum install automake autoconf
+
  yum install automake autoconf libtool
  
  
 
==== Setup rpmfusion repository ====
 
==== Setup rpmfusion repository ====
 
* LAME - rpmfusion is now preferred (better if you use nvidia cards, not really relevant for a buildslave)
 
* LAME - rpmfusion is now preferred (better if you use nvidia cards, not really relevant for a buildslave)
- See [http://rpmfusion.org/Configuration RPM Fusion Configuration]
+
See [http://rpmfusion.org/Configuration RPM Fusion Configuration]
 +
<pre>
 
  yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
 
  yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
 
  yum install lame-devel
 
  yum install lame-devel
 +
</pre>
  
 
=== MythTV Plugins ===
 
=== MythTV Plugins ===

Latest revision as of 14:23, 21 May 2014

Creating a Fedora Buildslave

stuarta 13:51, 3 March 2014 (UTC)

This is what you need to install to create a build slave running Fedora 18,19 or 20

Build Dependencies

Some essential basics

yum install gcc gcc-c++ ccache git gdb

Qt Library

Choose EITHER Qt4 or Qt5.

  • Qt4 is the current supported release across all versions of MythTV and all distros.
  • Qt5 is bleeding edge alpha quality at this time. Support is expected from 0.28 onward. 0.27 might compile, but has runtime issues

Qt4

yum install qt-devel qtwebkit-devel

Qt5

yum install qt5-qtbase-devel qt5-qtwebkit-devel qt5-qtscript-devel \
   libXinerama-devel libXrandr-devel libXv-devel
yum install freetype-devel

MythTV Core

yum install yasm libxml2-devel MySQL-python python-lxml \
   perl\(ExtUtils::MakeMaker\) perl\(DBI\) perl\(DBD::mysql\) \
   perl\(HTTP::Request\) perl\(LWP::UserAgent\) perl\(Net::UPnP::QueryResponse\) \ 
   perl\(Net::UPnP::ControlPoint\) perl\(IO::Socket::INET6\) \
   perl\(Date::Manip\) alsa-lib-devel pulseaudio-libs-devel
  • Bonjour library
yum install avahi-compat-libdns_sd-devel
  • 0.27 extra required rpms
yum install libuuid-devel
  • 0.28 extra required rpms
yum install exiv2-devel exiv2
  • for zeromq
yum install automake autoconf libtool


Setup rpmfusion repository

  • LAME - rpmfusion is now preferred (better if you use nvidia cards, not really relevant for a buildslave)

See RPM Fusion Configuration

 yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
 yum install lame-devel

MythTV Plugins

  • mythnetvision
yum install python-oauth
  • mythweather
yum install perl\(XML::Simple\) perl\(XML::XPath\) perl\(Image::Size\) \
   perl\(DateTime::Format::ISO8601\) perl\(SOAP::Lite\) perl\(JSON\)
  • mythmusic
yum install libvorbis-devel flac-devel taglib-devel libcdio-devel
  • mythzoneminder
yum install mysql-devel

Build Slave

yum install buildbot-slave python-twisted