QT4

From MythTV Official Wiki
Revision as of 04:02, 21 September 2009 by Davo101 (talk | contribs) (Changed libqt4-debug to libqt4-dbg (current package name).)

Jump to: navigation, search

QT is a software development toolkit used by MythTV as a framework for development.

Prior to version 0.22, MythTV was built using QT3. 0.22 will require QT version 4.3 as a minimum.

Most Linux distributions include a package manager, like yum which can install these libraries, and for those that compile from source, the development libraries. A typical command might be

yum install qt4 qt4-devel

Please refer to your OS specific instructions for installing packages or you can get it direct from the source

Isaac offers these suggestions on the mythtv-dev mailing list for those updating

A few tips for those updating:

- make sure you have the qt4 mysql library installed.

- do a distclean first, then remove any stray Makefiles that didn't get
removed by the distclean.  It may use the wrong qmake (ie, qt3's qmake)
otherwise.  I just did a 'find . -name "Makefile" -exec rm -f {} \;' from the
top level checkout dirs to fix this.

- The database updates will take a couple minutes to churn through and convert
the DB over to the new format.

Further notes from my experience. 1. Qt4.4 works - the min is 4.3, rather than requiring exactly 4.3. The lists don't make this clear, many distros now have 4.4. 2. Some people are getting a problem with a segfault after the scaling screen comes up. Delete all myth libs and bin files from your /usr or /usr/local, then rebuild, things come good. 3. OpenGL painter giving problems on many setting screens, use qt instead (may have to update db directly if you can't get to settings pages - table name is settings).

Temporary note for upgrading to QT4 from QT3 on Ubuntu

NOTE: I will update this as I go thru the process. This is a placeholder.

apt-get install libqt4-core libqt4-dbg libqt4-dev libqt4-gui libqt4-sql qt4-dev-tools qt4-qtconfig qt4-doc  qt4-designer

Temporary note for upgrading to QT4 from QT3 on Debian (Unstable)

NOTE: This should be enough.

apt-get install libqt4-core libqt4-dbg libqt4-dev libqt4-gui libqt4-sql qt4-dev-tools qt4-qtconfig qt4-doc qt4-designer