Difference between revisions of "Software Installation"

From MythTV Official Wiki
Jump to: navigation, search
(Call updated TOC)
(remove duplicate link, reorder some other text)
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
{{User Manual TOC}}
 
{{User Manual TOC}}
{{UpToDate 0.27}}
 
  
Install your Linux distribution using the individual install instructions for that distribution. There are links on the [[:Category:Operating System|Operating System]] page.
+
{{Note box|If you are installing remote frontends, they must use the same major version of MythTV as the backend. For example backend version 29.0 can support frontend version 29.0, 29.1, 29.2 but not 30.0.}}
 +
 
 +
Install your Linux distribution using the individual install instructions for that distribution.
 +
 
 +
==[[Packages#MythTV_Customized_Distributions|MythTV Customized Distributions]]==
  
 
If you are using a Custom Linux Distribution, MythTV will already be installed and you can proceed directly to configuring it. However you should first check if the distribution has installed the latest Release. If not you should update it before proceeding further.
 
If you are using a Custom Linux Distribution, MythTV will already be installed and you can proceed directly to configuring it. However you should first check if the distribution has installed the latest Release. If not you should update it before proceeding further.
  
 +
==[[Packages]]==
 
If you are not using a Custom Linux Distribution, you may be able to install MythTV using the distribution's package manager. This may install an out of date version, depending on the timing of version releases. In most cases there is an external package repository that you can access to get the latest MythTV Release.  
 
If you are not using a Custom Linux Distribution, you may be able to install MythTV using the distribution's package manager. This may install an out of date version, depending on the timing of version releases. In most cases there is an external package repository that you can access to get the latest MythTV Release.  
  
 +
==[[Build from Source]]==
 
If there is no appropriate package you will have to build from source.
 
If there is no appropriate package you will have to build from source.
  

Latest revision as of 21:33, 18 November 2021


Important.png Note: If you are installing remote frontends, they must use the same major version of MythTV as the backend. For example backend version 29.0 can support frontend version 29.0, 29.1, 29.2 but not 30.0.

Install your Linux distribution using the individual install instructions for that distribution.

MythTV Customized Distributions

If you are using a Custom Linux Distribution, MythTV will already be installed and you can proceed directly to configuring it. However you should first check if the distribution has installed the latest Release. If not you should update it before proceeding further.

Packages

If you are not using a Custom Linux Distribution, you may be able to install MythTV using the distribution's package manager. This may install an out of date version, depending on the timing of version releases. In most cases there is an external package repository that you can access to get the latest MythTV Release.

Build from Source

If there is no appropriate package you will have to build from source.

Select the appropriate guide from the menu below.