Difference between revisions of "Talk:Digital Audio Tutorial"

From MythTV Official Wiki
Jump to: navigation, search
m (moved Talk:AllensDigitalAudioHowto to Talk:Digital Audio Tutorial: There's enough attribution in the history, the wiki belongs to everyone, we don't need to name pages after ourselves.)
m (commentary moved into discussion page)
Line 38: Line 38:
 
Thank you.  This is what I had hoped to have someone verify.  Good news.
 
Thank you.  This is what I had hoped to have someone verify.  Good news.
 
Allen
 
Allen
 +
 +
This HowTo was written based on my system (MythTV 0.21 running on Mythbuntu 8.04) and comments from other users.  I have been told that the versions of Myth now in trunk treats audio differently. Apparently, .22 fixes is similar to 0.21 in audio as of this date so this HowTo should apply to MythTV 0.22.  It will probably need revisions for 0.23 which will be clearly marked if added.  One of the things that always bothered me in looking for how to do things when I initially solved this problem was that I could never tell if the howto I was reading applied to the version of Myth I was using.  So, now you know. Allen (10/16/09)
 +
 +
Unimportant Note: It really annoys me when I read a wiki and don't know when it was written and thus have no clue if it applies to my situation.  That is why I put in the above comment on 10/16/09.  I have no idea why someone decided to edit out my dating of that section.  I wrote this thing but apparently used two user names but that doesn't mean two people wrote it.  There have been some nice contributions, editing out typo's clarifying some things I said, and I hope someone will truly update this for the newer systems.  If they do, I would ask that they clearly state what they are doing, what version they are using, and the date they added it.  By the way, the original name of this howto (AllensDigitalAudioHowto) was suggested by the person who requested that I write it.  Allen (4/16/2010)

Revision as of 16:22, 16 April 2010

Allen,

I wanted to provide some feedback with my setup. I have an ASUS motherboard with ATI graphics (god forbid) and working SPDIF output.

I am using MythBuntu and upgraded to ALSA 0.19 to eliminate any problems early on. Using similar settings all things worked as expected.

Does anybody know what the 5.1 bug is about and if it is fixed in trunk? I'm getting correct digital audio, so I'm confused as to what is wrong.

Regards, Andrew


Allen, I am trying to get HDMI output working with my MSI K9N2GM motherboard and I followed your instructions to the best of my knowledge and still no luck. Any ideas on what I can do to fix it? Thanks, Dave

Dave, Send me an email and I will try and help you through it. Use this form http://paloaltophoto.com/index.php?index=4&subindex=0

Allen


Allen, I just came across your how-to and your request for verification around the HDMI parameters. I've used the HDMI procedure specifically on an ASUS P5N7A-VM and it works. You will need ALSA 1.0.19 (for this board at least). Users should also note that the MythTV setttings need to be set to "ALSA:default".

For reference, the syntax I use is:

pcm.!default {
type plug
slave {
pcm "hdmi"
}
}

I believe this is functionally the same as yours. --Christ 14:07, 13 April 2009 (UTC)

Thank you. This is what I had hoped to have someone verify. Good news. Allen

This HowTo was written based on my system (MythTV 0.21 running on Mythbuntu 8.04) and comments from other users. I have been told that the versions of Myth now in trunk treats audio differently. Apparently, .22 fixes is similar to 0.21 in audio as of this date so this HowTo should apply to MythTV 0.22. It will probably need revisions for 0.23 which will be clearly marked if added. One of the things that always bothered me in looking for how to do things when I initially solved this problem was that I could never tell if the howto I was reading applied to the version of Myth I was using. So, now you know. Allen (10/16/09)

Unimportant Note: It really annoys me when I read a wiki and don't know when it was written and thus have no clue if it applies to my situation. That is why I put in the above comment on 10/16/09. I have no idea why someone decided to edit out my dating of that section. I wrote this thing but apparently used two user names but that doesn't mean two people wrote it. There have been some nice contributions, editing out typo's clarifying some things I said, and I hope someone will truly update this for the newer systems. If they do, I would ask that they clearly state what they are doing, what version they are using, and the date they added it. By the way, the original name of this howto (AllensDigitalAudioHowto) was suggested by the person who requested that I write it. Allen (4/16/2010)