Talk:MythTV on Mac x86

From MythTV Official Wiki
Revision as of 03:15, 23 March 2006 by 24.3.244.218 (Build Status)

Jump to: navigation, search

Binary Packages?

Great work here! Thanks a lot for helping out the growing Intel/Mac community. But I have been trying these steps for two straight days with nothing to show for it. Are you guys ever planning on releasing binary packages? Or do you know of anywhere I can get them?


(tji) Do we have any place to host binaries at?

(Tux541) Sure, I have access to an open T1. Should do the trick.

(Tux541) Well I've posted a working version of Myth Frontend v0.19-Fixes without MMX support. Anyone who wants to download it can find it here:

www.wipzradio.com mythfrontend

(tji) Hey Tux, I finally got the MMX version to build.. Do you have an ftp server I can xfer it to you on?

(Tux541) Sure, ftp, login as anonymous and dump the file in the upload directory. As soon as it's done I will post it for you.

(tji) It's in transit now.. I just tar'd up the app and bzipped it. It is just the frontend, and doesn't include any of the plugins. Thanks!

(Tux541) Here is the updated version of Myth Frontend v0.19-Fixes with MMX support from tji.

www.wipzradio.com MythFrontend-MMX

Build Status

(tji) My current status:

  • 0.20 SVN non-MMX:

Frontend runs, communicates with backend, and can view live TV. My Core Duo mini is not fast enough to display smooth HD 1080i with this build.

I must have a MySQL version imcompatibility. My FE/BE communications have some problems.. displaying the list of recorded shows fails. I can see the data being transferred, but it hangs requesting channel icons ( 2006-03-17 10:17:23.454 MSqlQuery: SELECT icon FROM channel WHERE chanid = '1020' ; ) It hangs, repeating that sql request every half second. Anyone else seeing this?

(jpg)I had/have a similar problem [SELECT icon FROM channel]... it's not actually hanging for me, if you hit escape you will go back to the menu.

  • 0.20 SVN with MMX enabled:

Same as above, except 1080i HD displays smoothly, taking 85-95% of one CPU on a Core Duo Mini.

  • 0.19-fixes non-MMX:

Builds cleanly. Requires some of the older patches, since this branch wasn't updated with all the 0.20 fixes. All menus and program listings work fine. Can play live video or select recorded. Cannot play smooth HD video on Core Cuo Mini (needs MMX enhancements).

  • 0.19-fixes with-MMX:

Same as above, except MMX is working, and I'm getting video playback with less than 100% cpu.

MySQL

(Gaspode) Yes I have the same problem as (tji) - the Mac frontend communicates with the linux backend - and the linux backed responds - but the frontend does not seem to receive it.

(tji) Do you get complete failure of communication, or partial? On mine, I can view Live TV, and navigate some menus, but viewing the recorded program list fails, and navigating into setup menus fail.

running "mythfrontend -v all" from the command line shows more debugging info. When I try to access the recorded programs menu, it just scrolls the same message "MSqlQuery: SELECT icon FROM channel WHERE chanid = '1020' ;" I did a network sniff, and verified the communication is working, and the response appears to be okay, but the frontend doesn't accept it.

I'm wondering if it's a version incompatibility between MySQL client libs and server..

(Tux541) I had the same problem with mine, but only once. The very first time I tried to connect my frontend to my backend, after that it was fine. (TTT_Travis) I opened the app it showed the setup screen so I set it up and then when I open it it just hangs sorta, icon just bounces and bounces for like minutes then closes (Tux541) Try running it from a terminal. That happened to me when it can't connect to your database. If you run it from a terminal you will see it sits there trying to connect, then times out after 60 seconds, then tries again. If so try rm -rf /Users/*username*/.mythtv. This will blow out your settings, then try it again. This might be related to some of MySQL problems were seeing. By the way... What version of MythTV are running on the backend and what version of MySQL.

(Gaspode) Partial failure - Live tv works - menus work (except menus that trigger an sql query - (eg. setup, recorded programs) I used ethereal to sniff the network and the backend does respond to the front end. Also logged in to the backend mysql using the client on the frontend and verified that communication works.

I don't think it is a version problem (I have the same mysql version on the backend and the frontend) .It's either QT doing something strange to the data or the frontend itself.

(tji) Good info.. I'll try a newer version of QT, once I go back to messing with 0.20. I used the '20060321' snapshot of 3.3.6 with MythTV 0.19-fixes, and it worked fine there.