Difference between revisions of "User:Southern/Upgrading from 0.18.1 to 0.19 on Gentoo from Portage"

From MythTV Official Wiki
Jump to: navigation, search
(Starting)
Line 1: Line 1:
 +
[[Category:Upgrading]]
 +
 
===Shutdown===
 
===Shutdown===
 
Shutdown MythTV backend and any frontends
 
Shutdown MythTV backend and any frontends

Revision as of 23:09, 16 February 2006


Shutdown

Shutdown MythTV backend and any frontends

/etc/init.d/mythbackend stop

Unmasking

Currently MythTV is masked (~x86) in Portage

Add the following lines to /etc/portage/package.keywords

media-tv/mythtv ~x86
x11-themes/mythtv-themes ~x86
media-plugins/mythbrowser ~x86
media-plugins/mythvideo ~x86
media-plugins/mythnews ~x86
media-plugins/mythmusic ~x86
media-plugins/mythgallery ~x86
media-plugins/mythcontrols ~x86
media-plugins/mythweather ~x86
www-apps/mythweb ~x86

I don't have all of the plugins installed, so add any others that you will need.

Database Backup

mysqldump -p -uroot --all --opt --allow-keywords --flush-logs \
   --hex-blob --master-data --max_allowed_packet=16M \
   --quote-names mythconverg > mythtv_backup.sql

Emerge

emerge -av mythtv mythbrowser mythvideo mythnews \
   mythmusic mythgallery mythgallery mythcontrols mythweather mythweb

Wait....a while...

etc-update

Update the config files.

Starting

mythtv-setup

I just ran the setup program and then exited out.

/etc/init.d/mythbackend start

Problems

After the upgrade the mythbackend now runs as 'mythtv' user instead of 'root'. Not sure if this was related to just my install (I already had a mythtv user setup on the machine for the frontend). So I had a permission problem. Just chown the MythTV video directory to user 'mythtv' and everything is now working correctly. Also make sure the the mythtv user is in the 'video' group. If it isn't, recording or LiveTV isn't going to work for you.


--Southern 22:42, 16 February 2006 (UTC)