User talk:JeffSimpson

From MythTV Official Wiki
Revision as of 19:44, 14 December 2007 by Phiwum (talk | contribs) (Problems with DirecTV 12-300)

Jump to: navigation, search

Hey Jeff

I'm having some issues with directv.pl. I can sit in a terminal and run ./directv.pl off, on ,change channels and it works great. I go into mythtv-setup and add /home/mythtv/directv.pl to external command blah blah under input sources. Finish up and then run mythfrontend. Go to change channels.. nothing... nada. exit No errors listed during the use of mythfrontend.

Now I try to use ./directv.pl off,on, change channels.. it doesn't work anymore. I copy the fild to a new name.. such as directvbackup.pl Give it rights using chmod 755 to the file so it can be executed. Now magically the file works.. until I put it under mythtv-setup again and then it doesn't?!?! Is this a user rights issue? Only after I call on the script does it stop working.

Unfortunately, you didn't leave any contact info, so I can only hope that you found answers either on the mailinglist or that you'll check back here for help. Chances are, the problem lies not in the permissions of the script, but the permissions of your serial port. You need to give the user that will be running directv.pl permission to read/write the serial port device, through whatever method your distribution allows. I added the mythtv user to the "tty" group, and made my ttyS0 device group +rw.
- JeffSimpson 13:40, 9 August 2007 (UTC)

Problems with DirecTV 12-300

Hello.

I've been following the advice found here on the Wiki and elsewhere, trying to get my DirecTV box to work with MythTV. I've had partial success.

I found a script called directv3.pl, recommended by others for this box. I added /usr/local/bin/directv3.pl to the external change command, as directed, but when watching TV, the channel change does nothing useful. MythTV seems to think that it is changing the channel and I see "External Tuning program exited with no error", but the set-top box remains on the same channel.

Here's what's odd: from the command line, if I execute "directv3.pl 25", the set-top box does change to channel 25.

I'm flummoxed. Any ideas? Many thanks. Phiwum 19:44, 14 December 2007 (UTC)