Xbox Frontend on Xebian stable

From MythTV Official Wiki
Revision as of 14:29, 17 November 2007 by Rsp2k2k (talk | contribs) (ftp.sunset.se "sarge" directory/symlink missing, now using the "oldstable" directory.)

Jump to: navigation, search

Installing an Xbox Frontend on Xebian Stable

Alex Fisher has recompiled Christian Marillat's mythtv 0.20 source package against debian stable and optimised for Pentium 3.

The advantage with this configuration is that you do not need to upgrade any part of your Xebian from stable (sarge) to unstable (sid).

The steps involved with this are:


Install Xebian 1.1.4

See: Xbox_Frontend_HOWTO

Update Sources

I had to update to sarge to get mythtv to work, i read a mailing list that Alex had replied to that told you to update to sarge

Edit your sources.list to the following

deb http://ftp.at.debian.org/debian/ sarge main contrib non-free

deb http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free
deb-src http://non-us.debian.org/debian-non-US sarge/non-US main contrib non-free

deb     http://security.debian.org/ sarge/updates main contrib non-free
deb-src http://security.debian.org/ sarge/updates main contrib non-free

deb http://alexfisher.me.uk/debian sarge main
deb http://ftp.sunet.se/pub/os/Linux/distributions/debian-multimedia oldstable main


Now that your using sarge, you should probably update your distribution

apt-get update
apt-get upgrade

</pre>

Now that your using sarge, you should probably update your distribution

apt-get update
apt-get upgrade

Add Alex Fisher precompiled mythtv source

Skip this step if you did the above

Add the following lines to /etc/apt/sources.list

 deb http://alexfisher.me.uk/debian sarge main
 deb http://ftp.sunet.se/pub/os/Linux/distributions/debian-multimedia sarge main

Install MythTV

Run the following commands

apt-get update
apt-get install mythtv-frontend libmyth-0.20 mythtv-common

Known/Possible Issues

Jack Lowry has had a problem with his backend (Slackware 10.2, myth .19, mysql to 4.1.4) and his upgrading his xbox (xebian + mythtv 0.18 -> 0.19) with a mysql problem

But now I have a mysql version issue, when myth tries to make a 
connection to the mysql database I get a message in the .xsession-errors 
file that says:
ERROR 1251: Client does not support authentication protocol requested by 
server; consider upgrading MySQL client
I've also tried the mysql client and got the same error message.

It seems newer versions of mysql use a new password scheme that's compatible with the mysql client compiled into myth packages I was using. The following link provides several methods to work beyond this problem. I created a new user for my xbox frontend using the old format password.

http://dev.mysql.com/doc/refman/4.1/en/old-client.html

Another alternative is to check the my.cnf file on the server. It may contain an option to enable old-scheme passwords. Also, if you are unable to connect to the database check the my.cnf file to see if mysql is bound to an actual network address and not 127.0.0.1.